Nvenc hardware encoding on Linux Mint

Been some time now since I used Shotcut, but now that support is ending for Windows 7 I’ve decided to give Linux Mint a try. Since I’ve used Shotcut in the past it was the one I decided to use to edit my YouTube videos. I first tried the one from the Mint software manager, but It seemed to take a long time to render. Tried hardware encoding, but that only produced a black screen video with sound.

Someone suggested the portable version so I uninstalled the one I was using and downloaded the appimage file from the Shotcut download page. When I click the Use Hardware Encoder checkbox it says nothing found. I have a Nvidia GForce 9400GT which I thought should be able to work. Motherboard is a MSI P55-GD80 with i5-750 CPU.

Any ideas or am I just limited to CPU encoding? Thanks!

I’ve not tried Shotcut with Linux versions, but on my Windows 10 system with a GTX1070, I didn’t see much improvement when using the hardware encorder. I just leave it unchecked and the videos turn out fine for me.

Make sure you have the latest drivers for your Nvidia card. I’m on Windows and it was only recently that I was able to get Shotcut to detect my graphics card for hardware encoding after some update that Nvidia did on its own.

Thanks guys. I saw somewhere that hardware encoding has to be set in the config file, but using the portable version, where would one find that?

Okay thanks. Now please help me to understand. As this is a so called ‘portable’ version, are these files already present or created when Shotcut is run the first time?

I have not used the appimage to install Shotcut.
I use the portable tarball to install the application. All the necessary files are created, like a Windows install.

Okay thanks. Hopefully mine will be there. :slight_smile:

Please don’t waste too much time on digging hardware acceleration.

During the exporting, the encoding is the easy part (~20% of the total process), with or without hardware acceleration, the result time different will be tiny.

The hard part is the “Rendering” (making your timeline into frame-by-frame pictures, 80% of the workload), and this process is not hardware accelerated.

Okay thanks. I did find the config file and the hardware encoder was set to false. I changed it to true but when I click on the hardware encoder checkbox it still says nothing found. Guess I will just use the CPU encoder.

From Ubuntu:

The graphics chip must offer video acceleration
The associated graphics driver must support this (usually this is only possible through the proprietary drivers of the manufacturers, from kernel 3.13 also possible with the free driver radeon)
A suitable library for the API used must be installed
The video player software must support the API

Ubuntu site (german)

I’m sure you can have it in English too… :wink:

But, let me guess: Proprietary driver. :slight_smile:

HTH

Thanks. I am using the Nvidia driver for my card so if it has hardware encoding it should work.