Novice Users: Black Screen after rendering on Mac

Hello, am trying to teach some teachers about basic use of ShotCut as an opensource software that could be used across platforms. Went through about 100 teacher ed students this week without much difficulty but 1 issue stumped us.

Student on Mac created an MLT file–all looked good on a screen share. I could see all her edits, etc. When she went to render it (Export Video) as MP4, it created a black video with “INVALID” in white at the end. Her computer keeps saving to an icloud account–can’t see how to get it to save on the physical hard drive. Not sure if that’s an issue. The black video’s audio played but no video.

We tried renaming the export on another render, bringing the resolution down (was HD), resetting the export settings, renaming the MLT project, resaving it, even tried to export it as an AVI. It took time to render, but the AVI “file” that appeared on her desktop was only 225k–and had a cloud download looking icon. Tried clicking on it–nothing. There is no way the rendered video would be 225K.

After reviewing posts in this forum where people reported similar issues:
We tried to see if the student had added a filter to the “Master” or Output1 track–no filters were added to it.
We checked to make sure that the hardware encoder was unchecked. I will be meeting up with the student again (virtually) soon and would really appreciate any other ideas to try–or data to capture from the MLT that may help.

Any ideas what’s happening? Any help appreciated…

An iCloud-backed folder should not be a problem as I have tested that. It is easy to export to another folder - as basic as operating a file save dialog that you should be able to understand before attempting to edit video - a much more complex task.
You need to determine if the problem is specific to this project or a general problem. Make the simplest test by not loading the project, open a single file or generator (Open Other), and export to determine if it basically works. If so, then there might be something problematic in the project file, but you need to upload it here for someone to take a look.

Thank you. I will virtually meet with the student this week and try to figure this out. Through screen share I could see that the MLT was fully functional. Will try to get copy of the file pasted here.

Student solved issue by re-creating the file on another computer. So didn’t get a copy of the MLT to see what possibly went wrong, but appreciate the support.

1 Like