Normalize: One Pass maxing audio

What is your operating system?
Windows 11 (22621.3007)

What is your Shotcut version (see Help > About Shotcut)?
24.01.28 (bug was not present in version 23)

Can you repeat the problem? If so, what are the steps?
loading a project which has the 3 band equaliser filter on an audio or adding a filter set that includes it causes the audio to max out - can be seen in the peak meter and the heard with a pop then silence.

disabling the equaliser fixes it - altering the levels does (in my case all levels are minus values in my saved filter set)
if the filter is enabled the audio maxes out again
after disabling the filter to clear the problem if the equaliser is removed and then re-added (not from a saved set) then it functions correctly. though if this file is saved closed and reopened (in the same or new instance) the problem occurs again.

the preview must be played or use the timeline to move to a new point in time - after the load or filter set add to trigger the audio spike.

Have tried on multiple new files over last two days, only did not happen once - unsure what step was different to not trigger.

Happy to provide screenshots for clarity

EDIT: forgot to include that my filters are being set on the track, I don’t know if this happens with filters on clips or not.

I have not reproduced it yet on macOS (where I am at the moment). You mention “pop” and “spike” making it seem momentary and possibly only in preview. Is that so? What about export?

Update: tested in Windows too. Please provide steps starting with an empty project. Note the steps as you actually do them to verify that you can reproduce it.

Sorry for the slow response. I’ve come back to it today to see what I could add. I’ve reinstalled version 24 and actually struggled to reproduce, thinking perhaps a bad install, it until i checked an old project and that still had problems.

I’ve spent a bit more time and got what feels like the simplest steps to reproduce. I want to apologise now that I hadn’t previously understood the problem so you wouldn’t have been able to reproduce it. The problem seems to be a bad mix of filters that was working flawlessly in v23 and I don’t see why they shouldn’t work - but I’m not a professional by any means.

  1. Create new project (mine is using 1080 HD 60fps)
  2. Drag and drop source file into playlist
  3. Drag clip to timeline - which creates V1 track
  4. Select V1 track and open filters
  5. Add ‘Normalise: One Pass’ - Leave at defaults, any settings will cause bug
  6. Add 'Equaliser: 3-Band (Bass & Treble) - Leave at defaults, any settings will cause bug
  7. Play project preview - sound can be heard to pop and go silent audio levels are shown on max.
  8. exporting will create a video with no sound

Switching the order of the filters makes no difference.
Also happens if filters applied to clip on timeline rather than track.

Thanks, I reproduced it. The problem occurs using nearly any other audio filter with Normalize: One Pass. In fact, using Normalize: One Pass by itself even produces a loud distortion at the start of playback including the export.

1 Like

This is fixed for the next release.

2 Likes