No Video when using hardware encoder

When I export a file and use the hardware encoder function the exported file has no video, only audio.
Things I have tried.

  1. reinstall my graphic card drivers (GeForce GT 1030)
  2. configured the encoder to every one listed. (using h264_nvenc)
  3. uninstalled Shotcut and reinstalled software.
  4. watched loads of videos on how to use Shotcut.
    System: i5-7600 cpu, 16 GB RAM, Windows 10 64bit latest version and up to date.
    Hope someone can tell me what I’m doing wrong.

According to this table, you don’t have the NVENC encoder chip on the GT 1030.

1 Like

Thank you Hudson555x for your reply. So it seems that I can’t use nvenc encoder with Shotcut. I wonder if any of the other encoders i.e. amf or qsv are included in the GT 1030. I’ll try them out.
Question: Will not having support on my video card mean that the quality of my exported files will suffer?
Thanks again, Phillip

Not at all.

I’ve got a GTX1070, and don’t use the hardware encoding. It’s supposed to speed up processing time. I don’t mind waiting for things to render. But that’s my personal preference.

1 Like

I could be wrong but the current status of the quality of export using hardware encoding is not as good as regular exports using CPU. I believe hardware encoding is mostly used by people who want to export files quickly to use for uploads and whatnot. From what I understand, if you want to produce video quality that would be good enough for archiving then it’s best to use regular CPU encoding even if it will take longer.

amf is for AMD, and qsv is for Intel. It might be possible that your motherboard Intel chipset supports qsv (QuickSync), but sometimes you need to enable integrated graphics in the BIOS.

Thanks to all of you who have replied to my questions. I wish I had asked long ago instead of fumbling about in the dark.
It’s good to know that quality is not going to suffer for one and I’ll look into the support of qsv on my motherboard chipset.
Many thanks, Phillip

Correct. In general CPU encoding is focused on quality whereas GPU encoding is focused on speed - if you can accept lower quality or higher final bitrate then GPU encoding is for you as it will be faster, if your goal is highest possible quality at lowest possible bitrate then CPU based encoding will be your best option at the cost of increased encoding time.

I like the speed and lower temperatures with GPU encoding. I only upload to Youtube anyways, nothing serious.

I can only say thanks once again to all your information and advice. I can now concentrate on how to use the software to produce the best results for the videos I have and not worry about the hardware encoder.
On another note, I would like to thank the people you developed Shotcut. Really great software for me.

3 Likes

disculpad que escriba una solución para este problema en mi idioma, el español, pero a lo que nos lleva a solucionar
al descargar la última versión publicada a principios del año 2020, al exportar mis proyectos, me encontraba con el mismo problema, utilizo Windows 8.1 64 bits, sin tarjeta gráfica extra, tan solo la que viene integrada en el mismo procesador, un I3 de dos núcleos de 4ª generación y contando solo con 4G de RAM… pues al exportar mis proyectos a video mp4, solo se exportaba la pista de audio, mi solución fue intentar exportar con otra extensión, la correspondiente al codec de Windows, “.wmv”… con ese codec si aparece el video en exportación, espero les sea de utilidad a los usuarios de Windows, no es necesario tener una tarjeta gráfica específica para poder exportar video

Thank you Buscavidas, I ran your post through a translator to read it.
As Hudson555x pointed out to me, my video card doesn’t support NVENC. I’m happy to say that I have been working with my .wmv files and exported one, so far, film successfully in mp4 without using the hardware encoder. Still needs a lot of work but I’m getting there slowly.

That’s exactly why I’m also not using Hardware Encoder.

I will cover this topic in my next tutorial because I get a lot of inquiries about exporting films.

Well,I had same thing. No video when using hardware encoding. Lastly it was a novice failure.

I’m using a laptop with intel+nvidia. The only way I found to capture with obs was to disable nvidia card. When I tried to encode, the last encoding setting was using nvidia. That’s why it didn’t work. Enabled nvidia and it worked again.

Regards.