No video in export with Quick Sync Video hardware encoder (h264_qsv, hevc_qsv) in v20.06

I updated the software, now when I export a video, it is a blank white screen. I tried to save as different formats but still not working. I generally use the Youtube setting. mp4 not working, avi not working. Just a white screen when playback on shotcut or my video playback software.

Any suggestions would be great. This software has been a god send.

Thank you.

Did you go into the Advanced section and change settings?
If so, what did you change?

Make sure you are downloading/updating software from this site :
The latest version right now is 20.06.28. Not sure which version you have installed.

Is Hardware Encoding checked or unchecked?
If this is checked, have you tried unchecking then exporting?

OK. So I uninstalled the program and reinstalled it. I had installed it from the shotcut site. And am using the latest version.

I did not touch the advanced setting. The hardware encoding was checked. I unchecked it. Same thing happened. The thumbprint shows a note icon. Sound is there, video is just white. I tried playing on shotcut and on 2 different media players. It just shows a large metallic looking note for the video.

I installed a different video editor, openshot, and tried that to see if it maybe had something to do with my computer. I was able to create a video on this platform (although not as easy or as nice).

I would like to continue to use Shotcut, but need to get some videos done for an upcoming show.

Your time is greatly appreciated.

Keep in mind that we do not know your settings or steps. If you keep testing by opening an existing project, you should try sometime different to troubleshoot. Try this:

  1. start Shotcut
  2. choose File > Open Other > Count in the menu and click OK
  3. click Export > Export File, give it a name, and click OK
  4. wait for the export job to finish
  5. double-click the export job to open the result
  6. Is it all white? If so, click Properties in the main toolbar, take a screenshot, and upload it in a reply here.

Properties is too short to show anything useful, but white typically means it is audio-only. Right-click the export job and view XML, save it. Right-click the export job again, view the log, and save it. Upload both here please.

XML.txt (3.4 KB) Log.txt (1.6 KB)

1 Like

From your XML

From your log:

[h264_qsv @ 000000000dc5ba40] Using the intelligent constant quality with lookahead (LA_ICQ) ratecontrol method
[h264_qsv @ 000000000dc5ba40] Selected ratecontrol mode is unsupported

This means you do have hardware encoding turned on. Also, there was a change in the new version to use this “intelligent constant quality” mode, and now we know some chips are not supporting it. For now, again, turn off the hardware encoder in Export, restart Shotcut (to reset any state issue), and try again.

I have decided to revert this change for the next version 20.07 due in a couple of days so you can and others affected can return to using hardware encoder.

Same thing even with hardware encoder unchecked.

Never mind. I forgot to restart. That did the trick. Thank you!!!

1 Like

Thank you, Thank you, Thank you!!! Working well now. Very much appreciate it.

I may have another problem. When exporting the default settings, it is saving as ibx264. That works find. I just tried to save as h264_qsv, as that is what I usually save for Youtube. It reverts back to the white screen.

That is hardware encoding, which I explained is broken on your system after the update. Read above. I am repeating myself. You can also workaround this by using Rate control = Average Bitrate. It was the default Quality-based VBR on Intel hardware encoding on your older hardware that broke specifically. In any case, libx264 is higher quality than qsv and probably nearly as fast.

Thank you. I am an absolute beginner, so I don’t really understand all the terms people use. Thank you for the explanation. For instagram, I will have to change to Average Bitrate and 5M. Do you think I will have problems with that? I haven’t tried as I am working on YouTube and Facebook videos right now.

This topic was automatically closed after 90 days. New replies are no longer allowed.