No Upgrade Feature

Hi everyone. I’m trying out Shotcut for the first time. It looks interesting and I’m trying to disable the upgrade message. I found the page and I tried the command line method. I tried the -noupgrade parameter, with and without quotes, every combination I could think of. I also tried it by creating a shortcut. It always tells me that n, o, u, p, g, r, a, d, e are invalid options. I tried finding a shotcut.ini file. No luck. Before I resort to messing with the registry, can anyone out there tell me how to get either of these methods to actually work. Thanks.

Are you referring to the blue “click here to check for updates” box? If so, it’s not around long enough to worry about. If it’s not that, a few more details (Messages? What OS? When does the problem show up?) will help you find an answer.

I found the .ini file. It wasn’t even on drive C: ! It was off on drive F: where my data files are ??? I’'m running Windows 7. I am talking about the “Click here for to check for updates” box. I click. It thinks about it for a minute or so and shows me a new annoying message “You are running the latest version …”. That stays there forever. Since my earlier note I think there may be a bigger problem. In less than an hour the system has crashed twice. Not good. I installed video drivers before Shotcut. I’m going to roll back to the video drivers only. I will try them out for a few days without Shotcut. Thanks for getting back to me.

IMHO the update banner isn’t worth thinking about. There’s no action required, it goes away on its own, and it doesn’t cover up something useful. But then, I’m sure some people wish it would never show up at all. Takes all I kinds, eh? {/big grin]

Are you using a desktop or laptop? Specifically, if you’re using a laptop, your GPU and driver options are limited. I don’t want to think about number of times I’ve had to back out a video driver that did Evil Things. With a desktop, if nothing else, you can swap out the GPU (hey, all it takes is cubic amounts of money…) and get drivers known to work.

In general, Shotcut’s stable, but it does occasionally find time to …um… make the day interesting. On the hardware side, you can never have too many processors, too much memory, too fast a GPU. As is said in the racing world, “speed costs money. How fast do you want to go?”

Since it sticks around - that IS annoying. If it’s any consolation I found another instance of a banner that stays - even when you minimize Shotcut! It’s in the Linux version though.
Personally, I click on the check banner every time since I’m anxious to install the new version that contains keyframes. :grinning: -=Ken=-

I found out today when testing new v7.11 that this notification is sticking around on Windows (until it is replaced) on Windows when Settings > Display Method is set to DirectX. It also takes a while to first show up. All the status notifications in this area are behaving this way in that Display Method. Ugh

You have to use double-dashes before “noupgrade.” For some reason my site publisher is turning that into an en-dash. I will see if I can escape it and fix the post.

This is fixed in the new v17.11.04 by turning off the subtle fade in and out animations when using DirectX.

Thanks guys for your help. I got the noupgrade option to work but have run into a bigger problem. The video driver I had to install to run Shotcut is making the PC crash at random times. That’s even without having Shotcut installed. I need to visit Driver Hell and do some head banging and get that sorted out first.