No riple compensation when changing speed in v24.02.29

**What is your operating system?**Windows 10
(If you are using Linux, you must state how you installed Shotcut as there are too many builds and packages. In general, we do not make the build installed by your distribution package manager unless it installs the Snap. The developers only build, test, run, and support the builds shown on our download page.)

**What is your Shotcut version (see Help > About Shotcut)?**24.02.29

**Can you repeat the problem? If so, what are the steps?**I can repeat the propblem. If I want to change the speed of a section right clock opens porperties and I can change the speed, but it will not expand the section, instead cut the rest.
In a tutorial video there was an option “riple compensation” This is now no longer there. Please reinstate!
Thank you

Did you enable ripple in the timeline?

Yes, but it doesn’t help because it is not there in the properties where you change the speed.

It works for me. Maybe you can share a screenshot to show the problem you are having.

I think you are confusing this with Pitch Compensation. There was never a ripple option in Properties and probably will never be.

I have problems uploading the screenshot. How can I upload a jpeg?

In this clip there is an option riple compensation

That video is for Davinci Resolve. This forum is for Shotcut. That is a completely different application.

I apologize, didn’t regocnize this.
So what are the steps?
First enable ripple in the timeline.
Second change the speed in the porperties and apply?
That will not ripple the section.
So what am I doing wrong?

Yes, those are the steps, and it ripples for me too.

Does it also work for you if it is a vr clip?

Shotcut does know anything about a “vr” clip and therefore does nothing special with those. What do you mean by “vr?” I know of spherical and 3D. Those are simply video clips with special attributes not recognized by Shotcut; only the user knows about them (e.g. spherical projection) and what to do for special handling (e.g. use a filter whose name begins with “360:”).

Sorry, it was my handling error. It also works on vr. I just closed the app oppened the project again and then selected ripple not ripple all icon changed the properties and it worked.
Before I tested it on a 2D clip. So thank you very much for your help. Problem solved.
I will make a donation later as I’m very happy with shotcut. I was looking for something easy to use like windows movie maker that can handle vr and 4k clips and actually MS Edge copilot recommended shotcut. I had never heard from you nice tool before. Bye Frank

1 Like

I am glad to hear you got it working, and welcome to Shotuct and our forum! Don’t forget to use the forum search function; there is a lot of good info here, and docs (although not always complete) are prioritized highest in search results.