No preview / playback on linux

Hi, I compiled Shotcut 24.02.19 from source (on Gentoo) however I have no preview or playback.

When I load a video in I can get the player timeline to update with the length but pressing play does nothing.

I have tried both “OpenGL” and “Software (mesa)” for the display methods and the results are the same.

When I launch Shotcut from the terminal the only error I see is:

libDeckLinkAPI.so: cannot open shared object file: No such file or directory

Everything after that is formats and codecs. Trying to import and play a video doesn’t report any errors or print anything in the terminal.

I have tried several different videos to no avail.

I have OpenGL working on this system and other software can play back videos just fine.

I’d love to troubleshoot this further but without any error messages or indication of what is going wrong I don’t know what to check or try.

You should try to run one of the Linux builds we provide on our download page. I am not interested to debug your build. I suspect you have an unexpected combination of versions of MLT and Qt dependencies. I have heard from other Gentoo users here getting it to work.

I figured it out.

I just pulled down the git repo and built that which has tons of debugging output. It turns out for some reason it can’t use pulse even though other software can.

This is what the git build printed:

[Error  ] <MLT> [consumer sdl2_audio] Failed to initialize SDL: Audio target 'pulseaudio' not available
[Error  ] <MLT> [consumer sdl2_audio] Failed to initialize SDL: Audio target 'pulseaudio' not available

Changing the audio output to ALSA fixed everything.

The debug output was very useful. Probably the Gentoo ebuild for Shotcut should retain the output or else troubleshooting is impossible.

Thank you for writing the software :grinning:

1 Like

Maybe there is a SDL audio backend piece that needs to be installed. In any case, in case others arrive here that audio APIs selection is in the Shotcut menu at Settings > Player > Audio API