No more audio wave in timeline!


#1

Hi !

I’m a new user of Shotcut, and after few hours of use, the audio wave disappear in the timeline…
Impossible to see it again, after quit and reboot and also reinstalling Shotcut…

Let’s see on this screen capture : there is a video without the audio wave, but there is sound on the video !

Do you know how to make the audio wave appear again ?
Tx


#2

Try right-clicking the track and selecting ‘Rebuild Audio Waveform’


#3

I have already tried that, nothing is done…


#4

Oh well… :frowning:

(Post must be at least 20 characters!?
This is rather authoritarian isn’t it! Can this trivial restriction be lifted?)


#5

I have experienced this from HDV capture (mts/mpeg2). Audio seemed to be there, visible, playable, until a portion of it wasn’t. Then, I could play the audio but on export that portion wasn’t there. I tried Rebuild Audio Waveform but it didn’t work. The only solution for me was to capture again that portion of video/audio and was successful. I have no idea why this might happen. I do know mpeg video does exhibit anomalies at times when capturing and editing. I would first try removing and adding again the clip to your project.

-=Ken=-


#6

Under Timeline select the three lines for the timeline menu and select ‘Show Audio Waveforms’!!!


#7

I’ve got the same issue, mine is selected, i’ve clicked rebuilding several times, no result… it was there 20 minutes ago, on all pieces, now only on one audio track :confused:


#8

I’m in the same boat too. The waveforms vanished (from both video and audio tracks) on 18.05.03 and no amount of fiddling with settings or rebuilding (or reinstalling with the registry setting ticked) has made any difference. The issue is still present with 18.05.08 too.
You can see on the screenshot that the waveforms are set to display but don’t seem to be visible. Not a deal breaker of a problem that I can’t work around, but certainly a frustration with my work where audio cues are quite significant and the visualisation helps in placement. Hopefully they’ll be back in the next release.

edit - several hours later.

I was working on something this afternoon with the problems as described above. I went off to do something else for an hour or so and Shotcut was left running untouched. When I came back to it the waveforms were visible! I carried on working for a while then shut it down. When I restarted it a little later to tweak something on the same file - no visible waveforms again.


#9

(edited)


#10

Hudson555x18h1
Slide the window down to see the audio wave.

Doesn’t work for me.
The screen grabs below show the full depth of an audio track on the same project that yesterday displayed the (loud) waveform only after I had left Shotcut unattended for an hour but disappeared when reopened.

With short tracks

or tall tracks


#11

(edited)


#12

I think you’ve misunderstood me Hudson555x, though I do appreciate your efforts to be of assistance.

Whilst I am actively using Shotcut there is no waveform visible, however when I leave the PC or the software unattended the waveform is visible on my return. The hardware I’m using is a combo of storage - SSD for software & HD for storage. When I load a project and work on it, no waveform shows, no matter how long I am working. If I leave the software unattended it eventually becomes visible. The screengrab below is taken from the exact same spot as above but 75 mins later (I deliberately did not touch Shotcut in that time to see if the same would happen as yesterday), during which time the PC was in use on other tasks. The PC had also been in use on other tasks for 2 hrs PRIOR to the screenshots in the previous posts. During all that time the processors and SSD/HDs were kept active since I was working on sound files, vector gfx and script with frequent saves
I have been using Shotcut since the end of 2017 and this behaviour has not been present on previous versions, only since 18.05.03. I am confident it is neither because I do not know how to scroll down through tracks or that my HD is spinning down. Clearly it is not affecting everyone but it is hitting some of us as the OP and others demonstrate. Bug reports help the Devs of this brilliant piece of software make it better and suggesting that people reporting said bugs are unaware of basic PC operation could be counterproductive.


#13

With your most recent post, yes it’s clear I gave wrong advice. Good luck with your issues.


#14

Hi,
Im running Shotcut 18.08.01 on Windows 7 64 bit machine and also get wrong rendered audio waveform (audio plays fine but waveform is not present (interesting is that in keyframe window its rendered well). Rebuild audio track doesnt make any difference nor zooming in or out.


#15

With your keyframes window around 1:47, I see your actual playhead is at 2:42.


#16

Oh sorry, but the problem that it plays audio and no waveform present on timeline is still here. But now I restarted shotcut and reload project and the waveform looks alright now.


#17

Are you talking about V1 or A1? Keyframes is showing a video track (blue).
nm… just seen the last part of your post. :slight_smile: glad it’s sorted out.


#18

Ever since this issue first started, closing SC then reloading the project has occasionally restored the audio waveform display, now it does it every time :D. The problem doesn’t seem to happen so often in 18.08.01 but If I make multiple cuts to an audio track in a single session, the waveform can vanish or be misrepresented. I do that quite often in the series I’m currently working on because narration and video are recorded separately then edited together later, often with dozens of cuts per track. It’s nowhere near the huge PITA that it was a month or two ago and 30 seconds to shut down and restart/reload is not a huge price to pay now I only have to do it once or twice in an afternoon’s work.
I think now it could be more accurately described as a “quirk” than a bug.