No keyframes for Corner Pin filter

What is your operating system?
Ubuntu 18.04

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

When having Corner Pin filter with keyframes from previous versions of shotcut, it’s possible to edit keyframes. However when adding new filter in 22.01.30 version and trying to add keyframes, the pane for editing keyframes doesn’t appear. I’ve checked this with few projects. Restart of project or application don’t help.

FYI: That version works for me on Windows. What happens when you click the “Keyframes” tab?

Your layout may have become a bit screwy. You can always try the menu item “View->Layout->Restore Default Layout”.

1 Like

I tried add only “Corners”. In right bttm window you have three “tracks”: corner pin/corners/stretch x/stretch y. However me I have only “corner pin” and the next is not visible. It’s like you would hide anything from border between corner pin and corners on your sreenshoot.

Additional info. For Stretch X and Stretch Y everything works OK. Only Corners have problems. Restoring default layout doesn’t help.

Work fine for me on Fedora Linux 35 (Gnome) with flatpak version (22.01.30)

Did you open the project with previously created keyframes or fully new?

In general I have many small problems/buts/crashes with shotcut… I’m wondering is that somehow possible because of some linux libraries or even because of linux kernel? I have ubuntu 18.04 (with kernel 5.4) so it’s not the newest one but having not so powerful computer I’m not very enthusiastic about installing newer version (but still amd ryzen 7 3700u is not such a bad processor). Or perhaps it works better with nvidia graphic cards and their drivers? (I have only gpu embedded in processor).

Is shotcut more stable on Windows?

Returning to the merits, I really don’t know how to explain these differences. And why for stretch x and y and for other filters it works but here no. It’s quite strange for me… Like a bit different mechanism is used for corners here (by mechanism i mean perhaps other function, perhaps one parameter is different than in other cases etc)?

I created a new project, my laptop is not a power house, but handles shotcut very well.
On linux AMD is the best, because Nvidia is only making binary closed source drivers, while the AMD is included in the kernel.
Using an more up todate distro might be a good idea, because you get all the latest improvements.
Ubuntu LTS is good a server, but for desktop it get stuck in time and only get security related updates.

I have quite similar approach. The only thing which is coming to my mind is to move to newer version of Ubuntu. As for 18.04 I have already the newest software (including the newest possible kernel version as next work only with higher Ubuntu). I might consider it but it’s something which I’m not going to do in one night as I usually prefer to install fully fresh copy of Ubuntu and then it’s the question of install and configure all the software.

However it’s still a bit strange to have so many problems with shotcut…

You can try using the flatpak version, it is more isolated from your host system than other package types.

Here is how to setup basic support for flatpaks in Ubuntu

find shotcut flatpak here

Probably earlier or later I would be good to move to newer Ubuntu version. I would like to synchronize it with buying a new laptop but taking into consideration crazy prices of laptops it might happen I will have to wait…

If not, I will consider this flatpak version, even if I always prefer to install software from original websites.

It is Dan (@shotcut) there is doing the flatpak builds, so it is official.

1 Like

I just experienced the bug described by @ken_wawa.
Windows 10, Shotcut version 22.03.30

  • Clicking the stopwatch icon ( shotcut_QaVSUZHXFZ ) doesn’t add the first keyframe in the keyframe timeline.

  • Changing one of the parameters will add a keyframe though.

  • The Add a keyframe at playhead button ( shotcut_Plzt4bjuQs ) doesn’t work either.

  • To create an additional keyframe, I need to move the playhead and again change one of the parameters.

Also, if you notice, when the first keyframe is added in the middle of the timeline, a Hold keyframe is also added at the first frame.

This is fixed for the next release

This is a bug, but I did not find a good way to fix it. The corners filter is tricky because of the multiple ganged parameters. Maybe someday we will improve it to make this work.

This is still the case, unfortunately.

This is fixed for the next release.

1 Like

Thanks for the fixes.
For the other bug, as long as there is a workaround, we can live with it until you find a cure.

This is fixed now. I would appreciate some testing during the next beta period.

Thanks for your report.

1 Like