No key frames appearing after motion tracker analysis

I have a weird problem with using the motion tracker filter.

When I analyze the object I am tracking, the green preview window will track the object.

However, the analysis creates no key frames.

(I’m a new user, so it won’t let me put multiple images in a post. But trust me, the green preview frame is following Dagoth Ur properly through all 3 seconds of the clip.)

I’ve tried it multiple times, and it never generates a single key frame. So, no other filters can use the motion tracking data. I’ve even tried having other filters use the data, and since there are no key frames, the filters do nothing.

I looked at multiple tutorials on using the motion tracker, but I can’t figure out what I’m doing wrong. It should just generate the key frames, right?

Welcome!

Check if the filter rank is correct, in my understanding the motion tracker must be placed directly before the Size, position and rotate filter.

Not so, the filter that uses the motion tracker refers to it by name only when you click Apply inside the Load Keyframes from Motion Tracker dialog. Otherwise, the filter can be on a different clip either in Timeline or Playlist. For example, you can track motion in a video, and then apply that to a Size Position & Rotate filter on a separate text, image, or animation clip.

Analysis does not create keyframes; it creates data. A filter uses the analysis data to create keyframes.

Save your project, restart Shotcut, reopen the project and look at the Motion Tracker filter. Does it say “Analysis complete” next to the Analyze button? That is required first. Second, what is the Name in this filter?

Next, go to the Size Position & Rotate filter. When you click Load Keyframes and the dialog opens, do you see the Name from above? You need to choose it. You must ensure each dot is available and to connect the dots.

Yes, it says analysis complete and has a name:

image

It looked like this earlier today.

I’d post another image, but I can’t. But I did select the name in the drop down menu and select all relevant items in the load key frames menu.

I have the name of the filter. I set it to Absolute Position. And I set it to current position. It looked exactly like this earlier today.

But now it works?..

Okay, this is weird. Is Shotcut the kind of application that sometimes just needs a save and a restart to get stuff to work properly? Like, every hour or so?

Thanks for the help. It seems like I was doing the right thing all along.

Just for Motion Tracking, as far as I know.

I always make sure that I have a saved project before I attempt motion tracking.
So, nothing like: KyCnv5mRNv
And after Analysis is completed, I save again.
Maybe I’m just lucky, but by doing this, I never encounter problems when loading keyframes from Motion Tracker.

Thanks for the heads up.

After working with it some more last night, I noticed that saving before and after motion tracking did help iron out some issues.

1 Like