No images can be seen in video clip inserted between two clips


I have an ASUS windows 10 64 bit laptop.

I am facing a wierd problem.

Everything was going fine till i tried to undo a few changes in my editing.

The hard disk kept spinning but no undo happened. After awaiting a few minutes I tried to check with the task Manager - it showed shotcut was working, So I waitied for another 10 mins and in the end forced shotcut to close.

When I reopened shotcut there were no images whatsoever in the project, though I could play the clip as source.

I thouhgt may be the program had become corruppted, so I uninstalled shotcut, shut the laptop down, and after a few minutes reopened it. Still no images.

Same result when I unistalled and reinstalled shotcut again - after shutting down the laptop and restarting it.

There was no problem with the clip. When I played it on VLC, and windows it was fine.
Just then I saw that a new version of shotcut so once again I unintalled the old version and clean installed the new verision.

I still could not see any images in the old version so I deleted it entirely and started a new project.

This time there was no problem in playing two clips even in the timeline, but when I tried to insert a clip between the two, I can see the earlier two clips, but the central clip is blank. The funny thing is, this clip is a part of the first clip, that I had mistakenly deleted earlier,

I have nvidia rtx 3060 with i7 3.3 gig 11 gen processor.

I have already done a windows test, and a complete scan of the laptop with bitdefender to check for malware.

Please help. I am at my wits end as I am not sure if tt is a bug, or a problem with my laptop.

But then all other programs are working without a glitch.

I am really grateful for any help I can get.

I sincerely than everyone who takes time off to solve problems of newbies like me.

Dr Sugandha Johar

Further to my last post, I face the same problem when I try to add a video clip to a new video channel. There still are no images in the project window of the videos, though I can see the video as source.

In the last post I forgot to add my settings - here they are -

video mode - automatic
audio- stereo
preview scaling 360p
use proxy
hardware encoder hevc_nvenc
player - scrub audio, realtime (frame dropping), progrssive,
deinterlacer - one field
interpolation - bilinear
display method - Mesa
Job priority - Normal

Just tried something else. When the clip I added showed no video - btw, the proxy was done, I saved the project and closed shotcut. When I reopened the project, I could see the video that I could not see before.

I hope I have now given all the relevent details, and all the different things I tried to get the thing working like before.

CAn someone pl help me find a solution?

Sugandha Johar

BY now I have tried to insert or drag a clip into timeline at least more than 10 times, and each time I can see no images - nothing, the video section is blank.

However, once I save, quit shortcut and then reopen, I can see the video that was blank a few seconds ago.

The problem is only for video clips, jpg images open without a hitch.

Incidentally, Task Manager says that 54% of the memory is currently being used, and only 21% of total cpu power.

It might help someone to understand what is wrong if you:

  1. post a screenshot of the whole Shotcut window with your playhead positioned over the clip (e.g. using Windows’ “snipping tool”)

  2. uploadf a copy of the MLT project file

Do you still have the problem if you switch off “preview scaling”?

Pls. tell us something about the imported video clips: what format, codec, size, fps?
Maybe something with variable framerate from a smartphone or any spec. device?
What tool were used to capture the video?
Please also check the ‘video mode’ of your SC project - it should fit with the imported videos.
If they are variable framerate convert them to ‘edit friendly’.

havent checked that.

I had started using preview only because my laptop gets overwhelmed without it.

Rilo Naumann, and Neil - Elusien thanks for helping me with my problem.

I am using only .MOV vides shot on my Nikon D5600, the same source I used for videos made all of last year.
frame rate 29.97.
Same MOV
The video mode is automatic - the same as before the problem started.

how to I upload the screenshot and the MLT project? I had thought about it, but didn’t because I did not know how to

I see that

Mesa is usually a “last resort”. It is implemented in Software, not hardware. You appear to be running on a Windows system, so try changing the Display Method to “Automatic” or “OpenGL” or “DirectX (ANGLE)” and see if that sorts the problem. It should also use considerably less CPU and be more responsive.


But try changing the Display Method to see if that fixes the problem.


Changed the display method to automatic, but the problem continues. As a matter of fact it was automatic when the problem began so I changed first to Open GL, then DirectX and then lastly to Mesa to try and see if that resolves the problem,

All clips are use the following specs -
Codec - HEVC,
Resolution - 640X360 proxy,
Frame Rate - 29.970030
Format yuvj42p
colour space - ITU-R BT.601
colour -ITU-R BT.601
Aspect ratio - 16:9

I am enclosing the Mlt of the project.
a screenshot showing the image on displayed when the clip is opened, and
a screen shot with no image after the clip was added to the second track. The display and sound of the track above showing images on clips has been locked, the sound and display switched off.
Also noticed one more problem, shotcut has not made a proxy for the clip that is blank, even though I have set up both scaling and proxy. The third screen shot shows exactly that - no proxy even though the clip was added a few minutes before the screen shot. It is not even in process - shotcut has just not created a proxy.

I wonder if therein lies the problem.

When I closed shotcut, rebooted and reopened shotcut, miraculously the clip shows image display, and a proxy.

I hope I have now provided everything that Rilo Naumann, and Neil - Elusie you guys have asked for.

I am really grateful for all your help. It is this community spirit that I love here.


namak tax.mlt (60.6 KB)

Hi, Just back from a long weekend with very little internet connectivity.

I’m afraid I don’t know what else to suggest. I was hoping the Display Method may sort the problem, but as you point out it appears that for some reason Shotcut is not creating the poxy file on-the-fly that it would normally do. This isn’t something I can help with. It is more a question for @shotcut .