No audio synchronization with video in export

Hello,
I searched the whole forum and found a lot of statements in this topic, but no solution works for me. In short: I have two mp4 videos. From one I got rid of the sound, and from the other I left the sound alone. With the video I cut everything out to fit the audio clip. Unfortunately, after export there is no video synchronization with background music. I tested all the suggestions from other forum topics, but nothing works. The source video frame number is the same as the one being exported. I tried various export options - including export on default settings, but no effect. Next, I changed the soundtrack - I inserted a wav file instead of mp4, but it’s still exactly the same situation. Then I came up with the idea that with shotcut I can simply export cropped video and combine it with wav. Unfortunately, the same problem again. Again, I tried all the possibilities to change the export settings and it did nothing. I also tried to convert the video into handbrake to remove potential frame variables, but that didn’t change anything either, because the export was out of sync. I finally installed openshot, pasted there on one video track exported from shotcut + audio wav … and the export worked perfectly as I wanted - synchronization identical to that in the project. Can somebody explain this to me? I have been using shotcut for a long time and I would not like to change the program now because I work well with shotcut.

You need to provide more details of your actual problem.

What is the version number of Shotcut are you using?

What is your OS?

Please describe the problem in more detail. How is there no “video synchronization with background music”? Is it the entire time there is no sync? Is it in sync at the start but drifts as time goes on?

Did you try using Shotcut’s Convert to Edit-friendly option?

I’m using windows 10 and shotcut 19.09.14.

The lack of synchronization is manifested by the fact that the beginning seems ok, but after a few seconds there is a shift - the video is late compared to the audio.

Yes, I did - I used edit-friendly option with video and audio too, but nothing happens with synchronization when I put converted sources into app.

Today I tried again from the beginning to put the same two mp4 files (I delete audio from one and remove video from the other) without any conversion directly to openshot. I made a short film and after export synchronization works perfectly…

Thanks for letting us know what version number you are using. That version is from last year. New releases are almost monthly. The most recent version was released this past Saturday. Download the latest version here, try it again and let us know if the problem still happens.

And by the way, there has been a lot of new things that have been included in Shotcut since version 19.09. You may want to spend some time at the news section of the website and read about all of the fixes, changes and new features in each version that has been released since.

I don’t know how, but in the new version there is no problem with that thing :slight_smile:

Audio sync issues were addressed in the latest version. :slightly_smiling_face: Always make sure to check on Shotcut’s new releases.

Glad to hear it’s working for you now.