Newbie Question : how to turn off auto tiling of windows

Hi all, sorry for dumb question but when I try to undock and move sub-windows freely they automatically try to dock and thus prevent me from moving them freely. Can someone please tell how to disable this auto docking, any help appreciated thanks and cheers :slight_smile:

Look for an option related to window management or docking behavior then disable the auto-docking feature.

Can u pls tell which menu and submenu are you talking about that has this setting?

As far as I know, there is no way to disable the auto docking.

Here are a few tips that I’ve discovered when using panels undocked.

  • Auto docking follows your mouse to re-dock the panel.

  • When you undock a panel, resize Shotcut, then move the panel where you want it, keeping the mouse outside of Shotcut’s main program window.

  • Resize the undocked panel from the left, right, and bottom edges to avoid being re-docked.

  • To hide the undocked panel, turn off the panel in the View menu option.
    Example:
    shotcut_2023-12-18_11-11-20

  • To re-dock the panel, double-click anywhere on the title bar.
    shotcut_2023-12-18_11-17-23

  • You can save undocked panels as a “Layout”. View → Layout → Add. This also works for multiple monitors.

2 Likes

It is not possible, and it is the behavior of the GUI library we are using (i.e. I am not going to try to change it). You have to try hard to avoid places where it can be possibly be docker. Then center player area does not allow docking as well as anywhere outside of the main window.