Need help with SC download please

This is not a bug in SC of course, but I am using this category here, because it is meant for “bugs and problems”.

We are in Benin, West Africa, and beginning to love SC more every week. Late last night I discovered the new version (18.06.01) and tried downloading it right away. The change-log looks very promissing… But again it did not work. This morning I tried again, no joy.

I am a veteran user of FDM aka Free Download Manager. But even with FDM, the download failed. Several times. You see, those 184 MBytes typically take us one to three hours download time(!) So if something failes, it is frustrating and expensive (as most people here still pay per megabyte).

The download runs fine for say half an hour. Then it stops. FDM is giving me this strange entry in the logs: “Access denied. Invalid user name or password”. As there is not even a user name or pw involved, I can only guess this is an internal time-out on the SC web-server.

As OpenSource tools are so useful for countries like Bénin, where there is less buying power for commercial tools, it would make a real difference if the server could please be configured for more tolerant time-out settings or for users with potential ip-number-jumps during download. We have to use cell-phone internet-access, as there is nothing else here where we work.

Please check your download-logs, dear person in charge: You might be surprised that there are hundreds of failed download attempts from slow-internet-countries. So Shotcut could gain a wider user base, just by making your server a little more friendly. (I just tried one more time, downloading directly by Firefox browser and I also got a “Failed” after several minutes of downloading.)

For comparison: I regularly download fresh versions of Scribus, GIMP, Inkscape, Firefox, OmegaT etc. So I am not afraid of anything from 50 to 200 megabytes. It just takes a lot of patience (or letting my download manager run all Saturday, while I do repair jobs around the house). On most of the examples above, the download is just as slow as from the SC server, but I do never get those “access denied” problems (I sometimes get them from sites where I need to log-in like, where certain time-outs can throw my log-in).

Please ask if there are questions. As this will help other users with poor internet, I am willing to help with testing of different settings, if/when they become available. Thanks muchly.

I could really be wrong here, but I believe all of the files reside with GitHub or FossHub.
Which one are you using? I couldn’t find a link for FossHub, but a choice can be made based upon OS on the download page from Shotcut’s main website.

I am using on this site
the option for Windows 10 called Site 1 (GitHub), and trying to get this one:

The other option FossHub does work even less; downloads crash after a few seconds.

Are you saying that the SC-team has no way of configuring their presence on github? And that I need to write to some github support or forum about the “access denied” after several minutes download-time?

I have pulled other tools from github I believe (must even have some account and some installed-and-rarely-used GitHub Desktop).

But I do not remember ever struggling this much (except with some “huge” audio-files from an not-pro CMS-site in the UK, which was configured to never allow “ressume” when any download got interrupted).

I have an idea:

I could try using my GitHub Desktop tool to download. I would just need a few pointers from the SC-team on where to go and what to pull exactly. I do not need click-by-click instructions, can read any reasonable documentation. Maybe using the “official” GitHub tools and processes (rather than a humble browser or third-party-download-manager) I can overcome any time-out-troubles or else.

I just tried myself of course, before sending this reply: Seems that in order to access
with my GitHub Desktop tool, I need a username and pw. Not being a developer, what are my options please - or how can normal users of SC download through the GitHub tools?

I recommend you inform with a link to this thread.

You can download files from .

I don’t see a feature to download releases in Github Desktop.

You might get lucky with curl from*&cpu=x86_64 (3MB), extracting, going to bin/, opening a command line there (shift-right click in windows exlorer on white area > “open command window here”) and then running:

./curl -L -o shotcut-win64-180601.exe -C -

and repeating that command each time it fails. I used ctrl+c to simulate aborts and it looks like it worked.

I spent quite a few minutes, after the input from @Hudson555x, trying to download “my” release from github using GitHub Desktop. I want to help solving my own problems, so before I send any “yes, but” I test things.

Still, I consider it a refresher-course in github, which can never hurt.

Right now testing curl, which looks like a download manager for nerds. I am at just under 1% of download (1648 k) with so far an average speed of 3342 (whatever, maybe kbps) and an ETA of 17+ hours. It is Saturday and more local people are playing with Facebook or whatever. It will get faster again, normally we are getting at least one megabyte per minute.

Watch this space: I will later report here, if it managed to resume after any interuption. I am confident, that there will be interuptions. I could pull my network cable, but interuptions from our internet provider are worse, as I will normally get a new ip-number each time… So this note just to say thanks for the curl idea.

The curl methode looked really promissing:

I used this command, because ./curl looked rather Linuxy to me:

curl.exe -L -o shotcut-win64-180601.exe -C -

It run twice and stalled without error message. So I did ctrl+c and repeated succesfully.

Once it stopped with
curl: (56) Send failure: Connection was reset

and so I got to about 85 Mb out of 184 Mb and then it stopped with
curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.

Now it is over. I got further than I ever did with Free Download Manager but still no joy. I might give it another shot tonight. Maybe Saturday is when many nerds all over the world are coding and putting more load on the github servers…

But not your fault @qubodup, your idea is much appreciated. And I might well use this curl for other tricky downloads from now on. Good weekend and thanks.

1 Like

It seems that github’s Amazon S3 access token expires after like 5 minutes. This is why FossHub was offered. See this related bug report:

1 Like

Thanks, I read the other thread. Makes sense to me. Never knew you are dealing with so many downloads each month. (Still, I bet you could have more from certain countries.)

So I will experiment from now on with the FossHub option which at first felt much worse. Maybe that was just bad coincidence. I might try the curl-tool on the FossHub url, because curl did better than my old trusted download manager. I will certainly report here which constellation finally got it going.

1 Like

I have now tried the FossHub url with the curl tool several times, but at precisely 241k it stops each time.

If I try the -C - option, it gives me:
curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.

Maybe I am doing it wrong, this is what I used, based on the initial proposal by @qubodup:

curl.exe -L -o shotcut-win64-180601.exe -C -

and also

curl.exe -L -o shotcut-win64-180601.exe

Both syntaxes stop at 241k and resuming does not work.

If I did something wrong, please advise.

OK, that is downloading a web page that is 241K :wink:
The FossHub links (not my own design) do some trick to show their web page while the download occurs.

Did you try using a browser with FossHub?

1 Like

Yes I have since figured that out, but thanks for the hint, very kind.

I am right now downloading with Firefox: 7.0 of 184 MB (at 53 KB/sec (changes constantly)) ETA around one hour. We will see…


I have asked for help with the new download this afternoon. I tried several ideas from the thread (and am still trying right now, using the FossHub and my regular Firefox browser).

But some very kind user has created for me a private download today on some private online folder-thingy. That one I succeded to download rather fast (took about one hour, I do not have a log for that) and I have already installed the 18.06.01. So in the most literal sense I could mark this thread as solved already.

But for coming new versions (and maybe for many other users with very poor internet) I would love to be able to report later something like: “I went to this url and used this … and it worked better than …”. So please bear with me for another few hours or until Monday. (I do not go near my computer on Sundays, if I can help it.)

Seems that even today the version has gone from 18.06.01 to 18.06.02, right?

(Another detail which might interest certain users: Our uploads to YouTube are also a nightmare. If we go for HD and have some 500 MB it takes several days. But the good news we recently discovered: If you have to interrupt (storm, night, power cut, whatever) an upload, YouTube allows a resume, even one or two days later. So some servers are more tolerant with the resume feature than others. And since our uploads are so much slower than downloads, we appreciate this detail on YouTube.)

Update: :sob: Just noticed that while I am writing this, the browser-download from the FossHub url failed at just over 13 Mb. It gives me a “retry” but no “resume” option. Ooops: I just hit “retry” and it seems to be doing some sort of resume, now showing 13.4 of 184 MB. So there is still hope.

I wonder how to interpret this element in the FossHub url:
Probably some Linux-special counting system, which started at 0 (never at 1 of course) when Linus Thorwald had to sneeze in 1965 or something.

Final update: It worked!!! The download with Firefox from FossHub also stalled several more times. But each time it allowed me to “retry” and each time it resumed. It took several hours but the file was not corrupted and I am installing right now. Two new versions in one day - craaazy.

So in short: On very bad internet the FossHub url with Firefox can work very well.