Need help with qmelt by mlt file (if I run cmd from terminal)

Good day! Help Me Please.

If I run export from ShotCut then out video is nice.

But if I watch cmd from ps aux and run it from the terminal then out video is contains some artefacts.

in terminal I see errors:

[hue @ 0x7f1c0ac17940] [Eval @ 0x7f1c7dcf2520] Invalid chars '.5' at the end of expression '0.5'
[hue @ 0x7f1c0ac17940] Error when evaluating the expression '0.5' for b
[filter avfilter.hue] Cannot init scale filter: Недопустимый аргумент
[hue @ 0x7f1c65103480] [Eval @ 0x7f1c7ccf0520] Invalid chars '.5' at the end of expression '0.5'
[hue @ 0x7f1c65103480] Error when evaluating the expression '0.5' for b
[filter avfilter.hue] Cannot init scale filter: Недопустимый аргумент

I think this has something to do with environment variables.

Could you give me some advice on how to run the qmelt command correctly, so that it is identical to the command that shotcut launches?

Operation Systems: Ubuntu 18.04 x86_64, Ubuntu 19.04 x86_64
Shotcut version: 19.07.15 (installed from archive in /opt/Shotcut)

I solved the problem by adding the environment variable LC_ALL=C before running the build command.

The system was installed with the Russian language by default.

I had to study the state of processes in /proc to understand this. I hope someone will find the information useful)

A long time ago, melt and MLT added call to setlocale() to resolve a bug report that numeric values entered at the command line using commas does not work. The rationale was that the command line is a user interface and should be locale aware. MLT on Linux can understand the LC_NUMERIC="C" and apply the named locale to its own string-to-number conversions, but not all libraries. Here, MLT passes options to ffmpeg libs as string AVOptions since parameters are not strongly typed. So, one must set LC_NUMERIC=C in the environment to undo MLT/melt’s setlocale.