My PNGS get super pixelated over my videos


#1

Hey Everyone!

I apologize if this has been addressed before, but I’m having a bit of an issue. i’m making videos where i record myself drawing in the background, and use character stills in the foreground as i speak. the character stills are 1440 x 1520 PNGs with alpha channels. The recordings (i use OBS) come out at 1366x768 MP4s at 30 FPS. What I’ve been doing is stitching them together and applying the sound in Blender, but it all comes out looking perfect from that, then I use OBS to apply the character stills over that. Unfortunately, the PNGs end up quite pixelated and ugly looking in the final render. Even smaller assets (164 x 200) seem to come out this way. Any advice? I’m a bit lost and hopeless as it is. -Riley


#2

No need to format for this forum.


#3

fair enough.


#4

Can you post a screenshot ? or better, post a sample png ?

Most common cause would be an alpha channel interpretation problem. Your png’s probably have a straight alpha channel instead of premultiplied, but shotcut is probably expecting premultiplied. If this is the case, you usually interpret the alpha in the host program (I don’t think shotcut can do this yet) , or batch convert the pngs with something like ffmpeg so they are premultiplied


#5


#6


#7

You posted a jpg

I’m a little bit lost as to your workflow .

Are you compositing the OBS recordings with the character PNG’s in blender ? What export format and settings did you use to export out of blender? Where does shotcut come in ? Did you import out of blender into shotcut ? What format and settings did you use for the final render ?

The screenshot looks like it was from video playback. It might be as simple as using a higher bitrate for the video , but the deterioration could have been from jpeg compression too…


#8

so, here’s the long of it. i record in OBS. usually i have to pause several times, so when i pause i stop recording, then start again. putting them together i stitch all the video segments together, then render that into a full video in Blender. then i take that video, still in blender, and speed it up to the speed i want to make it match the length of the video’s script. i render this and bring it into Shotcut. in Shotcut i take the video and add the visual effects, as well as apply these character puppets on the track above the video itself, with the Size and Position filter over that entire track to make sure the puppets all appear in the same spot. i’m not sure why it converted to JPEG, it’s definitely a PNG.


#9

feel free to tell me i’m a psychopath doing it the most complicated way possible, i would not disagree with you.


#10

Blender has a video sequence editor too… but anyways… :slight_smile:

In that screenshot, the blurry quality loss around the lines on the blue shirt , is indicative of lossy encoding . It might be from jpeg screenshot, or it might be from the lossy encoding from whatever format your video was exported in

So what format and settings did you use ? Try a higher bitrate . Or even if you export a bmp or png , and the problem isn’t there, then you have your answer - the problem was your export setting

When you wrote "Unfortunately, the PNGs end up quite pixelated and ugly looking in the final render. " I’m assuming you meant the areas where you composited the PNG’s, not that you exported a PNG sequence


#11

you’ll have to forgive me, i’m a bit of a noob when it comes to these things. My current export settings:

export%20settings


#12

If it’s for general use , h.264 high profile in the left column is a good choice.

Select the “codec” tab and there is a quality level setting you can change .

If your OBS recordings were at 30FPS, is there any reason why this is set to 25FPS ? Normally you’d want everything to match . You will get jerky playback from the framerate mismatch as the 30FPS will get 1 frame dropped in 6 to make up that 25FPS


#13

huh, didn’t even notice the frame-rate discrepancy, thanks. and thanks for the advice! I’ll fanagle these settings a little tomorrow, see what comes out of it. i really appreciate the help.


#14

Depending on what you imported first will determine your video mode.
2019-01-08_20-35-47

You can create custom video modes in Shotcut.


#15

oh, so if i upload the PNGs first instead of the clip, the resolution will start to be prepared for them? cuz i dont actually care that much about the background being TOO clear, it’s mostly just something to be constantly happening because i’m shooting for an audience with no attention span.


#16

Shotcut expects PNGs to have straight alpha per the standard. In case this was converted to premultiplied by some tool or process, Shotcut has an Unpremultiply Alpha filter.