Mvhd timescale is 0 (unable to upload video to instagram)

When I try to upload a video from PC to instagram I get this error:
“mvhd timescale is 0”

is there any mp4 export settings that I can change to solve the problem?

Hi, you have to provide the export settings or the mlt file for diagnosis.

I just tested it on version 24.02 on Windows 11 using export defaults with NVIDIA hardware encoder (h264_nvenc), and it worked for me.

tutorial-borsina-caterina.mlt (14.0 KB)
tutorial-borsina-caterina-IG-low.mlt (14.0 KB)

Those are the MLT, i tried also different settings but still the same problem.

Can you suggests to convert the shotcut’s MP4 with FFMPEG or Mencoder to try (if yes, any suggested setting) to remove any doubt that is a problem with shotcut?

Try out the MKVToolNix. There is an option where you can correct the average frame rate and this tool is very fast because it does not decode and encode the content.
The output can be a mkv file or webm if the codecs are webm compliant.

0 is the stream number, in this file the video stream is 0 and the audio stream is 1.
the command line command is --default-duration 0:<your_fps>p