Motion Tracker not working in Square video mode (only HD 1080p)

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)?
23.09.29 (latest version)

Can you repeat the problem? If so, what are the steps?
Motion tracker with HD 1080p clip but with Square 1080p video mode doesn’t seem to work properly. Either it doesn’t show in the list of motion trackers (if it’s been analyzed when in square video mode), or the keyframes are not positioned correctly (if it’s been analyzed in HD mode before changing video mode to square). What’s further unsettling is that the tracker preview (bright green) functions correctly. All the problems go away if I go back to HD video mode, and all the problems reappear if I switch back to square video mode.

To repeat the problem (what I did):

  1. add clip to timeline (mine is HD 1080p 60fps) when video is in HD 1080p mode
  2. add tracker and analyze
  3. change to square video mode
  4. add text filter
  5. add keyframes using the tracker–they will be out of position even though the bright green tracker preview correctly follows the shape

Alternative problem:

  1. add HD clip to timeline when video is in square mode
  2. add tracker and analyze
  3. add text filter
  4. add keyframes using tracker: the tracker isn’t found (again, this is despite the bright green preview showing correctly)

If you change the video mode after you’ve made a tracker analysis, the analysis results are no longer valid - just the same as any other video filter that uses pixel coordinates. The results are pixel coordinates.


OK but as I wrote, analyzing the (HD) clip when the video is already in square mode also didn’t work. Basically I can’t get motion tracker to work for a square video currently.

For the alternative problem, people report that before several times. There was one fix in this area for the latest version, but I have not reproduced it since. I just tried again in Square 30p, and it is working for me including expected position/size.
Have you tried the workaround to save the project and reopen it?

1 Like

OK thanks for the info. I did try restarting shotcut, restarting my computer, etc., always same behavior. But I just tried on a different computer (Windows 10 also, same Shotcut version), and I did run into a problem at first (start in square mode, add clip to timeline, add track motion, analyze, add text, add keyframes: tracker was in the list but no keyframes were added), but it did work OK after changing video mode and changing it back (I switched from square to HD video mode, the keyframes were added correctly, I switched back to square mode, reset the keyframes, re-added them, and now it worked also in square mode).

So, not sure what the problem is, but seeing as the behavior isn’t the same on my two computers, I’ll simply figure out a way to make it work.

Thanks again for the help

Changing the video mode reloads the project. Here is the quick video test I made with 2 trackers. I did run into a little problem where the first tracker disappeared when I added the second one. I will look into that. It might be related.

1 Like

I don’t know if this helps but I just noticed that the relative position doesn’t work correctly in square mode (not me for anyhow), but “absolute position” and “size and position” work correctly (I don’t know about offset, I don’t know what it does). The relative position seems to be stuck in HD (even when I start with square mode), as when I switch to HD video mode the text is at the right place; the other two (absolute and size and position) work OK in square it seems.

My video above is square, and the text is using relative position.

1 Like

Sorry yeah I was editing my last comment, it looks like it might be because I first started the project in HD. that’s my bad of course, I should have started the project in square mode from the getgo, didn’t know I was gonna make it square when I first started the project.

I found this is a new bug in version 23.09 when switching the player to the Source tab. When I was doing this test, I went back to my clip in Source to trim a new sub-clip to add to the timeline, and this reset the list of tracker objects. I fixed it for the next version.

1 Like