Mlt files, filters and keyframes


When I export my .mlt file, the filters and keyframes are no longer there when I reopen it.
On the other hand, in the xml, the filters seem to have been saved.

I have text filters that I wanted to edit and add others, I have no access … disappeared …
Can you reproduce that?


I use Shotcut version 18.06.02.

.mlt seems OK after I modified file path.

But there is still a problem with the export: the text filter allows you to select “Use font size”: in the project view the selected size is good, but after export to mp4, it is no longer (justified in box).

Any helps ?

You have to click on the actual clip that you have keyframes on to see it again. When you open any MLT it always starts at 00:00:00:00, on Track V1.

You Save, or Save As to a mlt file. You Export to a file such as MP4, MOV, etc.

Not a bug. It’s just how Shotcut works.

This is different issue. You are have not presented any facts about your project. What file formats, file resolutions, or export settings are you using? Which Export preset are you using? What is your video mode set at?