Missing libxkb libs in prebuilt download

Good Day,

I’m curious to try shotcut, so I downloaded the prebuilt package from front page.
I’m on slackware 14.2 64 with multilib setup.

Shotcut says:

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in “”.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.

Reinstalling the application may fix this problem.
./shotcut: line 15: 30765 Aborted bin/shotcut “$@”

So I ran . ./shotcut to export the startup script variables to my shell, then I ran:
ldd ./lib/qt5/platforms/libqxcb.so|grep "not found"
libxkbcommon-x11.so.0 => not found
libxkbcommon.so.0 => not found

So I got the latest git from(via) http://xkbcommon.org/ and installed that, and then it ran.

Just thought you might like to include those two files in your prebuilt for thems who didn’t already have it.

But for me, I’m in business, once I get jack installed.



1 Like

A month later and this problem has not been fixed. I’m on Debian 8, 64-bit.

I can’t be bothered to jump through the hoops that Jesse did, so maybe I’ll come back to Shotcut another time. Or maybe not.


Do these packages not work for you?

libxkbcommon0 was already installed on my machine. Installing libxkbcommon-x11-0 allowed Shotcut to run, albeit with a slew of “Debug” messages in the terminal (is that normal?). libxkbcommon-dev and libxkbcommon-x11-dev were not needed so I didn’t install them.

Given that when Shotcut would not run, the error message was about “the Qt platform plugin “xcb”” and said that “Reinstalling the application may fix this problem”, I would certainly not have guessed which library I had to install to fix it.