Missing audio waveform with certain files

I’m using Shotcut version 22.09.23.

I’ve noticed that certain types of files I work with will not show audio waveform on the timeline. In particular, the files that have this problem are using audio codec “PCM S24 BE (in24)”. These are files recorded by an Atomos Ninja V recorder. I tried to trigger a rebuild of the audio waveform but it doesn’t do anything.

Other files recorded internally by the camera with audio codec “twos” seem to show the audio waveform normally.

In both cases, preview playback and export of the videos work fine and the audio comes out in the end fine. I just can’t see the waveform when I put the clip on the timeline.

What is the problem here? Is there a setting to fix this? Or is this a bug? Thanks for any help.


Just wanted to add something else. The audio is detected as “PCM S24 BE (in24)” from within VLC player and it plays back fine. However, when I put the same clip in shotcut, it detects the audio as “PCM signed 24-bit little endian” … and I’m wondering if that’s incorrect? Is the “BE” in what VLC is saying for “big endian”?

Also, if I take the same clip and just re-encode the audio to say, AAC, and use that file in shotcut, the audio waveform shows up just fine.

Have you tried turning off the higher peformance waveforms in the settings menu?

See here:

@Elusien Just tried disabling “High performance waveforms” under the settings menu. Still no wave forms. I also tried manually trigger a “rebuild wave form” and still nothing.

Any other ideas?

any other suggestions?

Sorry, the solution I gave worked for me. I don’t know what else you can do I’m afraid, other than possibly using the Convert option in “Properties” and see if that works.

This topic was automatically closed after 90 days. New replies are no longer allowed.