Melt.exe - priority vs. Alder Lake on Windows 10

Melt.exe is runing with below normal priority by default which makes it run using only E-cores but no P-cores on Windows 10 while using 12th Gen of Intel Core Alder Lake CPUs.

Switching priority of melt.exe to normal in task manager helps to make work it using all cores but only for one encoding run.

Is there any way to make Shotcut using all Alder Lake CPU cores for encoding permanently?

Or any chance to fix this to make encoding work using all cores?

1 Like

Changed this to a suggestion to add a configurable priority. This can affect other things than export such as convert, reverse, proxy, and stabilization.

This was implemented in 22.01.30:

“Low” is the default.

Please let us know if it works for you.

Doesn’t seem to work properly for me. Using i7-12700k

Seems to work at the beginning of video encoding then usually switches to 80-100% on e-cores.
Changing number of codec threads (in export file/advanced/codec) from 0 to 18 or even 20 doesn’t seem to impact. Even when Shotcut is the only task.

Did you change Settings > Job Priority to Normal?

Yes. I think the problem may come from that I’ve only 8 go ram installed right now. But anyway, I’m afraid it doesn’t use all p-cores. Usually 2 maximum. Will update when checked using 16 go asap :wink:

The amount of RAM should not make a difference. None of the developers have a 12th generation Intel core processor, and Intel and Microsoft should not have designed this such that an application needs to make code changes. I can understand that overall process priority might affect it, but a process at normal priory should not be required to make a code change to run on this new processor design.

Well, just finished testing with 32 Gb ddr4 ram. Yes, ram DO make a difference.

With 8 Gb, what I noticed is that only e-cores work at full speed, like I mentioned before. Balance is roughly 80-100% workload for e-cores, 5-20% for p-cores. What I noticed also is that p-cores workload is a bit more when pc is like in ‘idle’ mode (no other activity but Shotcut, not even mouse moves). This would confirm that 8 Gb of ram is a bottleneck. Ram usage being around 90%.

With 32 Gb ram, difference is QUITE noticeable. Balance between e-cores and p-cores is much better by far: e-cores and p-cores workload was around 50-70% each, meaning cpu was working almost at full speed (around 70% globally all along). Even surprised me when temp reached 80°C which I wasn’t expecting at all (first time with my new rig: I had to correct cooling settings in emergency !).

Ram usage was around 25% though so around 8Gb also. So maybe 10-12 Gb would be enough for cpu to handle all processes at the same time without having to make room for other recurrent processes almost all the time. Recurrent processes, from what I’m understanding, seem to be handled by e-cores exclusively. And p-cores workload don’t seem to reach high levels without e-cores ‘coordination’. Therefore, ram amount being important in my opinion.

Well at least that’s my understanding :grinning_face_with_smiling_eyes:

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.