Media duration does not match


#1

Hello again: I’m sorry to start a new thread with another bug.
I apologize in advance. I do not intend to disturb or bore you with this.

I created a new project 1920x1080p 25 fps
I imported a jpeg wallpaper (1920 x 1080) to the playlist.
The default duration of the clip is 4 seconds, however, the playback on the clip display stops at the value 03:24

The same thing happens when I drag the medium (image) to the timeline. The reproduction stops in 03:24

Additionally, I observe that the divisions in the timeline work strangely (in my opinion). There are no divisions until I drag the second clip to the right.


#2

This has always worked that way. I believe it’s showing 3 seconds and 24 frames which is equal to 4 seconds. If you look at the viewer display
image
the time spinner shows the position of the playhead, the selected duration display shows the length of the clip.

If you create a 1080p project @ 60fps the display looks like this.
image

This is the way SC works.


#3

However, the position of the playback line stops at a position that is not the end of the clip, as you can see in this screenshot.

After publishing the thread, I realized the matter of the 24 frames (my fault) :sweat:


#4

I believe the playhead stops there because that is the beginning of the last frame. If the playhead went any further, it would be at the beginning of the next clip and past the end of your project, which would effectively end every project with a black screen (because there is no next clip at the very end position).

To clarify what @sauron said, the playhead at 3s24f is equal to a duration of four seconds because the zero position also counts as a frame. So “frame 24” when you start counting from zero is actually your 25th frame if you start counting from 1, which puts the total duration at four seconds either way.


#5

I suggest you read this topic


You will see that Dan has worked on this subject and proposed a modification that I have installed and that I approve.
see the message 19/20


#6

I read that thread, but sometimes I do not understand the meaning of the words through the translator.
Given the situation I experienced, I thought about sharing this.
Thanks for the answers.
I regret repeating the report about a problem already addressed.

I have downloaded the ruler.qml file (from the related thread) and I have included the Shotcut installation folder.
It works well. Thank you.


#7

Remember to modify the “Ruler.qml” file in the “Keyframes” folder in the same way :wink:


#8

@austin is correct; it is not a bug.


#9

I changed the thread category because it is not a bug.
A greeting and sorry for my mistake. :pensive:


#10

Now I do. Thank you very much for the advice.


#11

Nothing to worry about, especially considering how much you contribute. I meant to comment on another thread where you had all the screenshots of Voxengo SPAN and Youlean meters. As a fellow audio engineer, you were speaking my language and most people probably didn’t recognize the amount of work you put into those replies. It’s extra impressive if you are doing all of it through a translator.


#12

Oh, thanks. You made my day. :grinning:
I’m not a sound engineer. My knowledge about this (and many other things) is limited.
However, I love learning new things.
I use the Google translator and Grammarly https://www.grammarly.com/
This helps a little and I am very happy to be able to interact and collaborate with my small contribution.


#13

@ejmillan Just a short note, you might want to try deepl.com as it tends to produce better understandable texts than Google translator.


#14

Thanks for the advice. :+1:
Any help is welcome. :grinning: