Maximize window in Linux

I don’t speak English. I write with the help of an interpreter. Why is it impossible to maximize a window in Linux OS? Linux Mint 19.1 Cinnamon. Thanks.

I do not know. It appears to be a problem with your window manager and possibly a combination of Shotcut and this window manager. I do not think our code does anything to tell the window manager not to show it. It works for me in GNOME Shell. As an alternative, you can use the full screen button at the the end of the toolbar.

Just to add I don’t use a DE but rather a WM and I have some odd behaviour with maximum window sizing. Different to OP.

When maximising the window, sometimes I get, well most of the time, I get a double menubar. One still functional.

Would I be correct in assuming this is more to do with the behaviour of Qt and the WM?

Anyway, it’s not a bother to and I’d be happier if energy went to other aspects of the project (such as midi controller implementation which I’m hanging out for)…

Just mentioning it for the record.

I just setup a virtual machine with Mint 19.1 Cinnamon, and I did not reproduce the problem using v19.02.28 flatpak (in Software Manager) or the downloaded portable archive or appimage.

fullscreen button doesn’t work either

To anyone else who has complaints in this area, debug it yourself and submit a patch.

I just started up Shotcut 19.02.28 in VirtualBox/Linux Mint 19.1 and the window controls are all there and work properly. I am using Xfce DE though. Kdenlive behaves just the same. A problem with Cinnamon?


The Cinnamon settings lets one change the window buttons that can appear. More than likely, this is the problem:

This topic was automatically closed after 90 days. New replies are no longer allowed.