Mask simple shape is not subtracting from top track to show bottom track

What is your operating system?

Linux 6.3.13

What is your Shotcut version (see Help > About Shotcut)?


Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

In the past I have been able to put a Mask: Simple Shape onto a video, select “Subtract” as the operation, and have the video underneath the one I am applying the filter to shown.

This is not working in the recent installation of 23.07.29.

See attached screenshots for reference:

With the top track hidden:

With the top track not hidden:

I would expect that the Mask: Simple Shape would subtract from the upper track’s video, to display a view into the lower track’s video with the Subtract operation.

I do not reproduce it. Maybe you changed the Blend mode of V2. Select its track head and check Properties. Over is the default.
Also, when you say you are using Linux you must also say how you got and installed it.

1 Like

Thank you for taking the time to look into this.

In the track head of V2, its properties were indeed set to “Over”.

Setting it to None did not change anything regarding the Mask filter.

I installed it via Pacman on Arch Linux. The previous version was 22.12.21

The screenshots are from a brand new .mlt project not created by the old version, but only used with the new version.

However, I have an old .mlt file that used to have mask subtraction working as expected with the previous version. Opening them with this one renders the same issue, in that the masks are not subtracted properly with the new version.

I will keep looking into this to see what other configuration could be messing with this.

Use a build that we provide. I won’t help you with a distro package.

Ok, that’s good to know.

I’ve installed the appimage and the issue is gone.

Sorry for the clutter.