Many problems when trying to edit a vertical video

Hello! I’m somewhat new to Shotcut and I’ve been trying to edit a vertical video I filmed on my pixel 5 for hours now, what I’m doing is somewhat simple but I’ve had issues on pretty much every step I’ve never had when working with normal 16:9 horizontal videos.

So the basics of what I’m trying to do, its take a 9:16 1080p video filmed on my Pixel 5, add audio recorded separately and then add an image with a couple effects as an intro to the beginning.

At first when I tried to do this, the edited video looked great in the viewer, but when I exported it it appeared at a much lower resolution with huge black bars on every side inside a 1920x1080 16:9 box. The properties of the file showed it as 16:9 as well.

I finally managed to fix this by changing the Option: Settings > Video mode > Non Broadcast > Vertical

But now, when I add in the image on the top track with a transparent background it shows the bottom tracks video in the same way as before - A teeny tiny video with a small resolution between 4 giant black bars - until the image on the top track is finished playing, then the bottom tracks video returns to its correct size and fills up the viewer at its full resolution.

I’ve tried:

 1. Adding a Crop filter to the top track and/or to the image in the track individually (nogo)

 2. Adding a resize filter to the top track and/or to the image in the track individually. (nogo)

 3. Right clicking the track and going to properties to attempt to resize the entire tracks resolution - this part confuses me because it says its at 1000 x 1000 resolution, the same as the image, but it doesn't give me the option to change the tracks resolution like I would normally see.

If there’s already been forums asking about this I do apologize, I couldn’t for the life of me find a video or forum post about this issue. ChatGPT was also no help.

If your vertical video is 9:16, try this: Remove all of the crop/resize filters, and anything else you might have done to fix this. Go to Settings→Video Mode→Non-Broadcast, then select “Vertical HD 30fps” (or 60fps, if you prefer). Alternately, you can go to Video Mode→Custom and add your own. Now, you’re editing a vertical 9:16 video which will output as such.

You could share your project file here on the forum so someone could test it and see what is wrong.

The project file is the file you get when you SAVE your project, and it has a MLT extension (example, myproject.mlt)

No need to include your video and image files.

I already tried this, I might not have explained it well enough in the post.

I was really hoping to avoid that, as i’m in the video and would prefer not to share it.

I understand if its too difficult to be worth attempting to help without that. Also sorry for the super late reply, i’m very busy but I do want to get this sorted out!

I would double check your Video Mode. If that still checks out. I would start completely over, with the mode set to the vertical 9:16 format. See if that fixes anything. Barring all of that, I echo the previous commenter about posting your project here so all of us can take a look. Something is being missed. We’ve all battled that at one time or another.