Managing video and audio fade outs

I want a 5 second fade out for video and audio at the end of a clip. I clicked on the clip, added the fade out video filter and set it to 04:59. I did the same thing with the audio fade out filter. The fade starts 5 seconds out and is done in a second or two. To make sure I had things right, I changed the duration to 09:59 and… the fade starts 5 seconds earlier, but is finished in a couple of seconds. I’ve had this problem before; eventually I get lucky and get the desired fade, but don’t understand why.

What’s the right way to do fades at the end of a clip?

Out of desperation, I created a 5 second block of black (“Open Other” and pick color) and appended it to the video track, at the end of the original clip. I slid the black block over the end of the original clip, hoping to create a transition to black. Rejected!! Shorter overlaps work, but, darnit, I want a five second fade out.

I put the block on a new video track and tried a fade in with opacity and… no useful result.

What am I missing???

After saving and reloading the edited clip, the throbbers showed up in the right places on the video and audio tracks, and the fades work as expected. Yippy, yippy, skippy.

Why don’t type-ins work?

Applying video fade in to a clip - I have found that I have to use the F5 key to make the visual fade show up. Sometimes it also helps to select another clip and then my current clip again. Once the fade becomes visible then hovering the cursor near the top portion of the fade, the cursor changes from a hand to an index finger and the “throbber” shows up. Drag the throbber to manually adjust the fade duration.

Incidentally, when the “thobber” is active a pop-up box appears showing the duration of the fade. Mine shows seconds and frames as expected but with a semicolon between. No biggie, but I don’t think that is a correct indication for English/NTSC/ATSC video editing.


1 Like

Thanks. [/smile] I came to the same conclusions.

I’m working on a re-mix of the first motorcycle video (by Alexander Thiessen)that really grabbed my attention. The fades are the first of that project. The open is an 11 second fade. The close uses only 3 seconds. I want the results to be within a few frames of the original. There’s no real reason for that accuracy, save I’m being anal about it. LOL

The next challenges are a fading text title, and a scroll for music credits.And at this point the project’s and Shotcut’s wheels fell off.

The scroll, of course, is a non-starter with Shotcut. Life’s too short to program, in HTML, scrolls to the right size and duration. BTDT and don’t plan to go back.

But the fading title should have been a near no-brainer. It wasn’t.

I created, on a separate video track, a block of color (I tried white and I tried black), with the alpha or opacity set to 0. NTL, the block remained persistently opaque. I tried turnin compositing off and on - no change.

As at least a test of concept, I added an HTML text overlay. And stepped into a minefield.

With the block over the main video (starts with the 11 sec. fade in), the best that I could do was fade the block out as the main clip faded in. When I could add the HTML filter, and used an opaque, not fade to/from black, fade. The text didn’t fade and, in general, the results were unusable.

The wheels… I started on my Linux machine (it’s faster) with the portable version of 17.11.07. Almost any time I tried to open or use the HTML overlay, Shotcut crashed. No messages, no clues, no nuthin’. After far too much time, I shifted to my laptop (was wicked fast in its day…). The results were the same. The block remained stubbornly opaque. Touching the HTML overlay produced instantaneous “no Shotcut no more” crashes. Not even the Win10 “we’re looking for a solution” wheeze - just Poof! Gone!

I’d write up a bug report if I had anything more specific than “touch HTML overlay, a color block with less than 100% opacity, and Shotcut dies”. Not much diagnostic info for anyone, except a mind reader, to work with.

End of comments/rant. [/rueful smile]

You may have to use a combination of video tools to get everything you want. Since you are willing to use Micro$oft Windoze there is a plethora of video tools available. I use the obsolete Keno application only for video capture, for instance. I try to think of Shotcut as a visual front end to FFmpeg and an incomplete application, almost a hobby for the developers. It does not have a proper titler although for home videos it is sufficient. It really, really needs keyframes which are promised by the end of the year. Other than that we can do some pretty nice visual editing that satisfies the lion’s share of basic home video editing needs. I am quite happy that Shotcut is the only really stable video editor I have found for Linux. -=Ken=-

Key frames - oh my yes!

You’re right about Shotcut being a good main line edit on Linux.

I appreciate, for example, the controls for managing the clock wipe. The edge can vary from very fuzzy to razor shape. Which is more than I can say for, as an example, Resolve (which pretty lame in the Linux setting).

It’s unfortunate that so much has to be outsourced to other tools, though.

Have you tried Lightworks with Linux?
I’ve used the Windows version and it;s been robust and very capable.

1 Like

At the moment I’m using “sneaker net” (unplug external drive from one machine and plug it into the other - amazing how fast a 1 Tb HDD can be copied via sneaker net!). Resolve, on a Win10 machine works well enough for my needs. I’m not a particular fan of BMD, but as long as Resolve works (somewhat uncertain)… [/shrug] there it is.

Isn’t that “pay for play?”

The free version has limitations but is capable of much more that SC.
You need to register an account and sign is every 2 weeks or so to use it.
I’ve used it now since June and have had no issues. When SC lacks a feature I use LW instead.:slight_smile:

1 Like

(First off… I like Shotcut very much. It lacks some, IMHO, fundamental features, but does others quite well. The Linux version can be infuriating for all of its crashes. )

Meh - at that point Resolve is a better bet. No need to keep the installation alive. However, my interactions with BMD, on their forum, have been anywhere from barely OK to thanks for nothing.

Resolve 12.5.??? has a Linux release but… no audio out without a proprietary A/V card ($145 for the least expensive card). There’s a V14.0.??? Linux release which is unstable at best, fails to launch often, and requires libpng12 although that’s now obsolete and replaced by libpng16.

I’ve tried to get some help with the installation errors (part of a thread from several users) and reported the libpng issue. Effectively nothing but crickets back.

The Win10 12.5 version (no cardneeded - AFAIK for the Mac version) runs but occasionally launches and then drops into hibernation. Several people reported that and… crickets.

A weird policy for the forum: You must use a full name (e.g., Orville Wright). Period. End of story. “RBEmerson” doesn’t cut it. "RB Emerson doesn’t cut it. BMD tosses you for using a non-approved name. BTDT

In short, do things the Blackmagic Design way or hit the highway.

BTW, the licensed version, which AFAIK is heavily used in “Hollyweird”, is now down to ~$250 from four figures. Maybe support is better. If it’s handled in the forum, support doesn’t look any different. And there are still the cards.


1 Like