Make texts without any borders have smooth edges

If I set thickness to 0 while adding a text, the edge is not sharp. But, if the thickness is more than 0, the text’s edge is sharp. please add smooth edges to the text that has thickness 0 setting.

IK There is rich text, but it is pretty glitchy and I cannot explain.

Hi @Rasthro
If your text is on a transparent clip, it needs to be place on top of another clip: Video, image or color clip.
If you don’t want a clip below your text, add your text to a color clip instead of a transparent clip.