Major file crash

A file that I had lots of work into suddenly crashed. I had been saving along the way (MHT). When I reopened the file, it displays “Invalid”. I’ve tried several attempts (on file-copies) to repair the .mlt file, but have gotten nowhere. The Shotcut auto-repair file does not produce a repaired job either.

I hoping there is some chance of repair. Here is the file:
GTO - Cameo.mlt (28.3 KB)

(the original *.mpg is, of course, not uploaded. It’s ~4GB)

Any help is appreciated.

Your project includes itself. I do not know how you did that; we try real hard to detect, prevent, and repair that. Here I fixed it for you manually.
GTO - Cameo - Fixed.mlt (27.0 KB)

Thankyou very much, but it did not work. Shotcut crashes upon opening this file.

A quick glance of the fixed file you sent appears to be the same as I uploaded (has same project references to resource “GTO - Cameo.mlt”) - mind you, I am only taking guesses of what this all means in the .mlt files. - just trying to relay information.

Before, Shotcut wouldn’t crash but brought up the “Found errors dialogue box”. (I let it make repairs, opened that repaired file and got the “INVALID” display. Shotcut would play when that file was opened opened, the timeline of the Shotcut-repaired file looks to be accurate, and the play time-counter IS moving as if it is playing, but only displays “INVALID”.

I do not believe there is anything wrong with my Shotcut installation - I tried a test run with a new project, and it works normally.

Snooping around Shotcut:
The ~AppData\Local\Meltytech\Shotcut\autosave folder is empty.
The ~qmlcache folder has lots of files

(FYI, when the crash initially happened, the computer was very busy, and I think I tried starting another program. I definitely tried doing something when I knew I should have let the computer sit.)

Continuing, in the project file GTO - Cameo.mlt, I manually replaced all the “property name=“resource”>GTO - Cameo.mlt </property” lines with “property name=“resource”>C:\Users\Lou_2\Desktop\DVR Toolbox\DVR#2 KT6JC08599 R - Living Rm\2021 0613\DVD_RTAV\Hold\GTO - Cameo - Copy.mpg</property” (the path and source of the originally worked video file). The project, GTO - Cameo.mlt, opens with the video source, but it does not include any of the edits nor are the edits shown in the timeline - actually, I did notice one tiny edit included.

I believe the edits are lost unless otherwise informed. Is this likely its state?

Yes, this was some sort of file-fix-resend mixup. Also, the file is much larger - it’s more on the order of 1MB; I ended up redoing the editing.

Further, I don’t know how the original error happened -

Pro Tip: Save your project with a new name every so often so that if the project becomes corrupt or broken, you can easily open the previous project file that worked.

Good advice.

I would like to mention that other than this rare crash (again, which was my fault) Shotcut has shown to be very resilient; at times it may take a long time for it to progress through, but it does get through. I have even terminated the program during one of these, reopened the project, and the project was up date.

This topic was automatically closed after 90 days. New replies are no longer allowed.