Lost files on drag/drop from flash card - Where did they go?

I should have copied them first, but dragged from my flash drive into the new project window and nothing happened, apart from them disappearing off my flash drive.

They must be somewhere, right? Any help appreciated - it’s all my holiday videos from my GoPro.

Feeling gutted right now - Thanks in advance.


Shotcut did not do it. The only files Shotcut deletes is its own generated thumbnails. It is possible that whatever OS you are using did something bad when dragging from its file manager. However, I suggest that you simply eject the flash drive, reinsert it, and see if the files are there.

Thanks - I tried that, but they’re still not on my flash drive. I reinserted back into my GoPro to play on preview, and not there either. To confirm, I highlighted my .mp4 files (total of 54) and dragged over to the Shotcut new project playlist window (as I’ve done many times before) - and instead of loading and appearing one by one, the files just erased from the viewer of my flash drive and nothing happened. They’re also not in the newly created new project file. I’m on Windows 10, and apart from loading being a bit slow sometimes in the past, I’ve never had this happen before. I’m really hoping someone has an idea - I have 60 to 80 mins of family video shots.

OK, then it sounds to me like Explorer did not observe the Shotcut window as the target - I have seem that before: sometimes there is a lag while it builds thumbnails of what you are dragging and is not yet observing your desired target. Then, you release too soon, and it moved the files to somewhere else on the filesystem, and that can be hard to find. However, it should only move when the target is the same drive; otherwise, it copies when going between drives. So, look around in different places on the flash drive. What is the used/available drive space on the flash drive? Does it make sense if all the files seem to be gone?

Yes, definitely gone off the flash, the memory has freed up quite a lot. I just don’t understand what has happened - I watched all 54 files move with my mouse (as a file picture with 54 on it) it went into the playlist window, I let go of the mouse button and nothing happened - apart from all the files going ‘somewhere’ - I feel like I’ve been mugged! Really appreciate your help.

I still need help - But I’ve since done a ‘simulated’ action to see where I could have gone wrong - Here’s what I found:

When I highlighted my 54 files I kept my finger on the ‘shift key’ which causes the files to ‘move’ - (if you don’t press shift, they ‘copy’ - So in error, for some reason I just pressed ‘shift’ again after highlighting my files, and during the drag to Shotcut, they ‘moved’ - hence they are no longer on my flash.

I just tested again into a new file with a few other ‘test’ .mp4 files, and they too have now disappeared off my flash, and NOT appeared in Shotcut where I carefully dragged them to.

So the question now (same question really, but with better details) where do files go in Shotcut when ‘moved’ and not ‘copied’ during the drag and drop?

Thank you

That too is up to Windows Explorer since Shotcut does not copy files either. Shotcut simply gets a list of files that it reads from. Why would it need to move or copy them - especially as either operation would require extremely careful handling? So, it doesn’t. I just what you did and reproduced it, but I do not know what Windows did with it. That is crazy! It does not appear in Shotcut either, and Shotcut’s log shows no trace of it as if it did not receive anything. The file is not in the Recycle Bin, Desktop, or the Shotcut program folder. If Shotcut receives it, it would show in the log like
[Debug ] <Playlist::AppendCommand::redo>
and if it was the very first file in the empty window before it something like
[Info ] <MainWindow::open> "E:/DCIM/100GOPRO/GX010044.MP4"

The reason Shotcut’s Playlist panel accepts a move operation is because reordering the playlist items by drag-n-drop is a move operation. Other panels such as the player or Timeline does not accept move.

Thanks for testing it - I appreciate your time. I did a cmd search using ‘where /r’ (for c: and d: drives) for the files that I ‘moved’ and they are not anywhere on my system. I also checked the Recycle Bin, and they have simply vanished. I really don’t get it. I’m furious too - at myself mostly for just keeping my finger on ‘shift’ causing it to move and not copy in a split second - and in doing so have seemingly erased all my videos in half a second.

I hope I’m wrong and there’s a solution.

I made a fix for the next version to prevent that bad behavior on Windows. Shotcut’s Playlist will reject drops that have a combination of move action and file names data. This rejection makes Windows behave by not following through with the file removal. I am sorry it was exposed to you. It is worth noting the other operating systems such as macOS and Linux GNOME do not exhibit this destructive behavior. I am not saying I hate Windows; just very surprised that it took this destructive action especially after the billions of people who have been using it for decades. You’d think something like this wouldn’t be possible.

Have you tried going back to your flash card and CTRL+Z?

You can add an undo button for File Explorer.


Hi @dean01 - sorry to hear you have lost your files. This is probably no help but I use “Everything” search program which I find is a fast way of searching for files - way faster and superior to the Windows search. Just an idea you might want to try.

1 Like

I just tried that, it did not work unfortunately. Thank you.

Thanks @jonray I downloaded ‘Everything’ - it did not find any files. I’m gradually coming to terms with the fact that a ‘move’ of files into a Shotcut window, rather than a ‘copy’ simply eliminates the files instantly into electronic quark dust. I’m totally devastated - literally got home today, put my micro card into a USB to ‘copy’ all files into a Shotcut project to edit vids of our family vacation to Florida… and, yeah. I just can’t even… thanks everyone for trying to help.

Oh no, I’m sorry to hear about your precious files. Feeling for you…

Have you tried any recovery apps (I’ve used a few years back Recuva free version, I don’t know if it’s still good) - just make sure not to record other stuff over it and you should be able to recover at least some of the files.

1 Like

Thanks - You mean recovery from the SD card?

Yes, the original location.

1 Like

Or if the files are precious, maybe you could send the drive to a specialist file recovery person or company. A friend of mine (a teacher) recently lost ALL her Powerpoint files from her laptop hard drive (which were essential for her teaching). She sent off the hard drive and got the files back. Cost her 500GBP (650USD) but it was worth it to her. Just a thought.

1 Like

Resolved!!! I can’t believe it!! Big shout-out to @daniel47 - I did a basic scan of the SD card at the start of the issue, but not until you mentioned a ‘recovery app’ that I even thought about, or realized this was even possible!! I searched for the best rated one, and it seemed ‘Wondershare Recoverit’ was the best for 2023 - It cost me $80 for the cheapest option (one month use) but wow, so worth it when all my family holiday videos started re-appearing from the ‘deep scan’… It’s amazing, I mean how is that stuff stored on an SD card after deleting?? I need to now google that, I’m really intrigued. I’ve only got a 256GB SD, and it recovered over 500GB of videos… Amazing. Made me wonder how many people this technology has ‘not’ been helpful for, if you know what I mean!! Anyway - Lesson learned… ‘copy’ files to Shotcut, don’t ‘move’ them. Thanks to everyone pitching-in to help - nice community of people. Cheers everyone.


Wow, @dean01 - I am SO pleased you got your files back!! Woo Hoo for you!! Congrats. :smiley:

1 Like