Linux: MAJOR jackd problem

Xubuntu 18.04

21.05.29 64-bit

Can you repeat the problem? If so, what are the steps?

Yes. Using a new Shotcut session, enable jack support. Then Open File and add a video that got audio. The audio will bypass jack totally and will blast at the loudest possible volume.

I create music. I use Yamaha powered monitors and subwoofer. LUCKILY the hardware volume on each speaker was relatively low, at about 4 for the highs and 2 for the subwoofer. So no harm was done to the equipment, I can’t imagine the blast it would have been with the Yamaha hardware audio set at 7 or more. There could have been hardware damages caused by this as far as quality of audio delivery is concerned.

This is major problem.

Apart from this, the sync between software works well. When Play is activated in Shotcut Bitwig also starts playing. It would be so cool to have Shotcut AND Bitwig working together in real time with proper audio since this would allow to make music changes at the same time the video is created. Instead, a stereo export has to be done from Bitwig, then imported into Shotcut to build the video.

The shotcut player view has it own volume control , It is set to maximum by default
it is not a problem when using pulseaudio, but when using Jack, you might want to turn it down, because jack don’t use the normal system volume control as pulse does.


1 Like

Please prove this point as the only way I can reproduce it is by doing something intentional to break the JACK connection. Nothing will be done about the volume other than Tim showed you. It is bad behavior to arbitrarily lower the volume because it is using JACK or because you complained about it. You need to explain better what is happening at the technical JACK level what is wrong because as this stands it is an invalid report.

Hello ! This dates from some time ago, but it happened again, totally unexpected as I always use Shotcut with headphones except for that other time recently. The volume control was at -20. As soon as a first clip was opened to add to the project audio went blasting through the powered speakers. Not loudly, but blasting. No time to do anything but to reach for the power switch on the subwoofer (Yamaha HS system). But as soon as the power was shut I look at Shotcut’s volume control and it was at -20dB.

I create music since quite a few years. I use Bitwig and Mixbus32C native Linux software. Before that I was using Ardour. I configured Linux audio so many times.

Now there’s another problem. There’s no sound out of Shotcut, through the headphones, after this happened. I cannot get any sound of it whereas at the same time I can play videos on firefox, I can use mpv to play any audio/video just fine, But no sound comes out of Shotcut, now at 22.10 (today’s version). Moving the volume slider in Shotcut does not change anything. As I type this, Shotcut is playing the video, no sound, mpv is playing a video with sound, firefox is playing a video no problem.

Is there a main audio on/off switch as part of Shotcut ?

What can be done to bring the audio back ? OS is Xubuntu 18.04. I upload regularly videos and as such I’m using Shotcut on a regular basis, no problems at all.


At the bottom of the volume slider in your screenshot is a speaker icon with an X on it. This means the output audio is muted. Click the button to toggle it.

EDIT: Scratch that. I assume now it looks that way while changing volume to get the screenshot and returns to unmute when you’re done.

The ‘x’ seems to be fluctuating. Here are three screenshots. At first there’s no ‘x’. And no audio. Then I hover the mouse over the volume cursor button and the help text is shown. When I actually click on the cursor button to vary the volume (still no audio out) the ‘x’ immediately reappears. Last screenshot was taken including the mouse pointer.

Sorry, I was to include the three screenshots but a new user can only include one. I could make three replies although I’m not sure it’s needed to prove the behaviour of the software.

So this is the 3rd one. I might as well post the one before.


The one before, showing the help text, before clicking on the actual cursor button. There is clearly no ‘x’ but then there’s no audio neither.

I’d be glad just to have audio back and use headphones.


By the way, I’d like to either remove ‘jackd’ from the subject line or create another thread. I have no technical proof that jackd is involved although it is always running on my system.

Also, is there a debug mode for Shotcut in which debug messages can by output ?

I tested this on Linux and it is behaving as designed. But maybe the design is unexpected to you. In its normal state, the button shows its current mode (muted or not muted). When you click the button, it pops up a volume control and a button on top that allows you to change the mode. So the button on top shows the opposite state so you can see what you would change it to. So basically, you have to click twice to change the mode: once to show the volume/mode button and then again to click the mode button.

As the author, can’t you edit the title?

Not a “debug mode”. But you can choose View->Application Log… to see application messages

Hello ! I have found the symptom of the problem as far as it goes, from the log file. I have several screenshots so this will spread through a couple of replies. First I would like to establish the technical basis of the system I use as far as jackd is concerned.

This is the command line. It clearly shows 44100 to be the clock setting.

This is reflected by the mudita24 configuration software for the Envy24 / LT1010 audio card.

And yet, looking at the Shotcut log we see :

[Error ] [filter jack] mismatching frequencies JACK = 44100 actual = 48000
[Error ] [filter jack] mismatching frequencies JACK = 44100 actual = 48000
[Error ] [filter jack] mismatching frequencies JACK = 44100 actual = 48000
[Info ] [filter fft] Buffer Reset 1:0
[Error ] [filter jack] mismatching frequencies JACK = 44100 actual = 48000
[Error ] [filter jack] mismatching frequencies JACK = 44100 actual = 48000

This goes on and on.

It looks like Shotcut considers that it should be 48000 when in fact it is 44100.

I checked with Bitwig and Mixbus32C (which is based on Open Source Ardour) and they do not have, rightly so I think, any specific sampling rate that they cling to. Which makes sense as they are talking to jackd which in turn takes care of that. If every software using audio on a given system would insist on a specific rate, I wonder what jackd would do, no to mention the chipset on the hardware audio card.

We can easily ask Paul Davis, creator of jackd and Ardour, about that. There’s absolutely no problems in asking.

It looks like for some reason after the ‘blasting speakers’ incident Shotcut has enabled jackd. I disabled it and now the audio is in its normal configuration, which means it goes through Pulse audio on Linux. Pulse audio in turn goes into a Pulse audio jackd sink and audio is out through two of 8 stereo outputs of the hardware LT1010 audio card. This is how every other non-jack audio software makes its audio heard.

So I switched back to regular audio in Shotcut and now I have sounds coming out, which is great.

In the process I did a reset on Shotcut 22.10. Now that I’ve specified the location of all previous Shotcut projects, Shotcut 22.10 will not load them automatically, which is understandable I guess. Or maybe it should be a new feature. If that’s the case then I can write a feature request about it.

As such, the subject line will not need to be modified because it’s after all about jackd. I’d say that Shotcut should no expect any rate, unless there’s a solid technical reason behind it.

Why not change the clock to 48000 ?

In music making there are a whole lot of buttons, knobs, sliders, switches and so on. Tons of them. In DAWs themselves and in the many software synthesizers. They are all modeled on real-life mechanisms which means that the state or whatever a control object shows is not drastically modified when a user touches it. The only change that is shown is the one the user imparts to the control.

As such, yes, I’m not familiar with the slider behaviour you are describing.

I have hundreds of music composed and recorded at 44100 which is the CD-friendly rate. I wouldn’t really want to go through the conversion of all these as I revisit some from time to time. While at it, 96000 would be a much better rate, if I would change anything regarding that. I wouldn’t go half-way, to change again later and converting again with eventual errors in conversion.

I wouldn’t recommend doing that. It would be a prescription to potentially destroy all your old work and having worked in IT for years, I’ve heard sad tales told about when it goes wrong.

Just leave your library as it is. Make sure that it’s backed up well.

It’s like moving from HD to Full-HD or 4K in video. It’s not advisable to go and upscale your entire archive of work if something new comes along. Just leave your old files the way they are.

Work on a few new files with the new format and see how it goes.

At some point, a better upscaling tool is likely to come along. So in a way, the longer that you leave your old Music Archives the way that they are the safer they may be.

It’s just general advice, they’re your files and you can do with them what you want.

Indeed ! It’s common sense regarding this.