Linux Desktop Shortcut - How?

Hi,
On Linux Mint 19 xfce, I extracted, 19.12.31.txz portable, which appears on the desktop as a shotcut folder.

Inside are 2 files; a red shotcut ‘exe’ and, the main shotcut program folder.

How do you create a desktop shortcut (from the red exe)? I’ve tried everything, including the long winded Terminal/VIM methods, and the Launcher method, but none work.

This is how it looks like with my Linux Mint 18.1-64 KDE:

Screenshot_20200202_113034

Screenshot_20200202_113043

If you have extract that TXZ file, then you can rename it (maybe because of a better overview).
Then you can simply Drag&Drop that “Shotcut.desktop” icon where ever you want.
I put it into my Taskbar…

HTH

@ Earlybite
The first thing I tried (didn’t mention it in the original post) was dragging the “Shotcut.desktop” icon from shotcut folder to the desktop.

Didn’t work.

Then made a shortcut of “Shotcut.desktop” icon still inside shotcut folder, and put it on desktop.

Didn’t work.

Hm, maybe a xfce “thing”? Or by Linux Mint 19.1? I do not know… (I have Linux Mint 18.1-64 KDE).

But maybe, what means exactly “Didn’t work”? An (error) message? Have you had a look in “System Activity” (STRG+ESC)? What about, if you double click directly on “Shotcut.desktop” icon in the folder, where you have extracted it?

Shotcut only opens if, “Shotcut.desktop” icon inside the folder, is clicked.

“Didn’t work” means… when you click on the desktop shortcut, nothing happens.

Then it should be a “Linux Mint thing”…

Even if nothing has happen, something has happen. :wink:

But, ok, I really think it’s on Linux Mint side. Check your settings for Links…, maybe the Linux Mint Forum? Or someone here can help further…

Running Fedora with KDE plaxa I have the same issue with the Shotcut launcher.
The launcher will not start the application unless the command is changed.

I open the properties and change the command by browsing to the shotcut.app folder and selecting the wrapper script.

image

Then the launcher works, and I make a link to the launcher on the desktop.

1 Like

I’ll try that, but it seems the problem is with my xfce desktop version not playing with the Thunar version - a know problem, apparently.

In case, it’s still actual…
I now have Linux Mint 19.3 Cinnamon and I only get Shotcut started directly with that ‘Shotcut’ icon (from the txz file).
My solution is to make a bookmark in the file manager (in my case ‘Nemo’).