Levels histogram appears in output when set to 'none'

The histogram from the levels filter seems to be produced in the output even if it is set to ‘none’ in the filter. It seems to happen randomly, and it appears to be a non-reproducible fault.

I used my Google-fu and searched the forum before posting this, but couldn’t find an answer.

I shoot in 4K 10 bit dlog, apply a LUT to bring the file into REC709, adjust levels and apply the Hue/Lightness/Saturation filter just as a final tweak. All three filters are applied at the same time. I confirm the histogram is off and then export file - and the histogram is still there!

There is no audio, and audio is disabled in export->advanced tab.

I am using Ubuntu 18.04.4 and version 20.02.17 of Shotcut.

It’s frustrating because some jobs take quite a while to run, and then the output has the abovementioned major defect that means I have to do it all over again - and it might happen again.

Has anyone had this happen and is there a workaround?

Best Regards - Eye.