Latter part of the video a black screen with only sound

I am using windows 10

It’s a 64-bit version
so, I finished working on my youtube video and exported it but to my disappointment, the video was cut in half and the latter half is just a black screen with the voice going on. I am so disappointed to know my hard work went in vain. Can someone pls tell me what I did wrong?

Your screenshot is only showing 2 video tracks, and 1 audio track.
The audio track appears to be 2x longer than your video tracks.

On the 2nd video track it appears you have another clip that is not in view on the screenshot.

1 Like

The video track is composed of stock footage I found from the web and the exported video and the video in shortcut got cut in half. the audio track remained the same length but the latter part of the 1st video track that is shown in the screenshot has been removed. The stock videos that I put on the track disappeared.the first half is fine but the latter part its just audio and everything in the video track is gone

will send a screenshot after some time
thank you

[quote=“dion_John, post:3, topic:28040”]
The video track is composed of stock footage I found from the web and the exported video and the video in shortcut got cut in half. the audio track remained the same length but the latter part of the 1st video track that is shown in the screenshot has been removed. The stock videos that I put on the track disappeared.the first half is fine but the latter part its just audio and everything in the video track is gone

@Hudson555x

I am trying to understand may have happened.

In all screenshots, you are showing a repaired video, which means somewhere along the lines, you would have got a dialog box pop up asking you to fix the file. What is not clear is what happened to repair your project file. Was it missing files that you needed to relocate, or something else.

While you have AI - Repaired.mlt, you should also have AI.mlt .
Copy both of these files to a different folder or drive as a backup before proceeding.

What did Shotcut want you to repair with your AI.mlt file?
Can you upload both mlt files here? Just drag & drop into the reply window. We don’t need the source video/image/audio files.

It might just be as simple as going through the repair process again and finding missing files. If you have moved or deleted video/image files, just put them back where you may have moved/deleted them from, and attempt to reopen AI.mlt .

1 Like

I had a missing files dialog box pop up but thank you for your support.
I fixed the problem.
the steps I took to fix it was as follows:
1 I opened AI repaired file where the latter part of the video was deleted
2 I pressed option save as and replaced the file with the original AI.mlt
3 And I simply deleted AI repaired.mlt
4 Then I added my deleted video clips from the recent tab in shortcut
I guess there was some problem with my file but after doing these steps, exported my video and it came out just fine

Thank you for your support and concern

1 Like

And I moved all my video clips to one folder