Lag when skipping individual frames

Could be a bug, feel free to move…

I’m finding frame-by-frame scrubbing buggy, when everything else (including playback) seems to work as expected.

I occasionally use Shotcut 21.06.29 (i see after July, this is important) on a laptop which is not hugely powerful i3 / 8gb ram intel HD3000 integrated graphics.

I’m generally editing 1080p video.

I noticed yesterday that while playback of 1080p .mp4 video is fine in the preview and timeline views, Shotcut struggles (lags) when I scrub one frame forward or back (via the arrow keys). Audio scrubs fine. It’s just the video which freezes on a certain frame for a while.

This seems counter intuitive to me, how can Shotcut not render 1 frame per keypress, when it’s happy rendering 30+ per second in playback?

Is there a setting I’m missing.

Try using proxy. Maybe you can explain your workflow a bit more.

Firstly, thanks for the reply, it’s great shotcut has such a good community.

No disrespect, but I’d hoped the first answer wouldn’t be proxy. I’d rather learn other editors which don’t need me to use proxy.

For example, neither blender nor KDEnlive suffer the problem described below, using 2560x1440 footage on the same machine.

The reasons I am (trying) to use Shotcut are:

(1) because I can’t get a fast enough workflow in blender because of the UI.

(2) for consistency; my main PC (i7, 16gb ram) has an Nvidea card, which doesn’t play well at all with the current build of KDEnlive, and I’ve had no responses to my support requests from the KDEnlive Community.

With that out the way, I’m happy to elaborate on my workflow. It’s fairly standard. What do you need to know?

If it helps, I use frame-by-frame for the same reasons most do. Setting in and out points (preview and project views), aligning clips with audio beats / SFX (project view).

You are probably at the low end of the spectrum for power. i3 doesn’t specify how powerful the chip is, rather it’s just a brand description/classification.

@Sheep is correct in suggesting Proxy.
Along with Proxy, utilize Preview Scaling.

This is also suggested in the FAQ.

Also try restarting your computer and only use Shotcut when editing, leaving all other applications off. If your data drive is an HDD (Hard Disk Drive) and if it’s the only one you have, that is the slowest way to do video editing.

Yes it is a low end processor 2310m (the whole machine cost me £32)

On the sysreq, my cpu is 2 cores short for HD, but has enough ram. However preview lag is only present when skipping individual frames with the keys. Playback (space) and scrubbing (with mouse) are acceptable.

Again, no disrespect, but all I’m hearing is “your PC is too cr*p), so there must be no other problem”.

I’m not saying that’s not the case, its a very low end device. However, needing proxy in Shotcut in order to skip individual frames with the arrow keys is disappointing when (as above) KDEnlive and blender work fine on this machine.

Edit: I should also say, it has an SSD

Before I proxy a project to test. Is there anything else I can try?

May i know what is your Video Mode (Setting>Video Mode). Do you have the same fps in all of your clips?

Thanks for getting back to me,

I stick to video mode HD 1080p 30 fps as I render for YouTube and my lowest resolution camera is 1080p.

Some of my projects use variable rate .mp4 footage which is nominally 30fps.

Footage used (accross the board on all devices is):

  • 2560x1440, variable (30.05) fps, h264, mp4 container, 48khz aac audio

  • 2224x1080, variable (30.05) fps, h264, mp4 container, 48khz aac audio

  • 1920x1080, variable (30.05) fps, h264, mp4 container, 48khz aac audio

  • 1920x1080, 30fps h264, AVI container, pcm_s16le audio

Newer projects use only the latter two. Issues arise regardless of the source footage type.

I proxied (540p) a small project while we were discussing. Even with preview scaling, no change.

I took OBS captures of the issue yesterday. I’ll get them up somewhere if that helps?

Edit: there seems to be some kind of offset / buffer issue, when skipping forward, normal service resumes after about 9 frames forward of the playhead. When skipping backward, no such luck.

Shotcut doesn’t do very good with variable frame rate videos. With each variable fps file you should convert those to Edit Friendly.

shotcut_2021-09-02_10-07-45

With your Video Mode set to 30FPS, and each file is not directly 30FPS, Shotcut is constantly recalculating what is the next frame.

Thanks, I don’t have a lot of hope here, as the project which gave me the issue is mostly fixed fps (30) avi files.

I tried Brian’s batch convert method and after the 4th or so file Shotcut crashed out.

I’ll try again.

Daft question here but Is it not possible to put Shotcut on your “main” (i7) PC?

Shotcut is on my main i7 PC (and works lovely) but I can’t take it, and it’s two 27" screens anywhere.

Meanwhile, you guys may get a laugh from knowing:

  • my little (12-inch) i3 lappy has currently got all 4 cores (threads?) pegged and throttling at 88°

  • it will be like that for at least another hour or so while it batch converts (thanks brian) this project.

  • I’ve had to take it off my lap, the plastic base is 58°

Man I love messing around with computers.

Ok so the batch convert seems to have worked, and now I can skip frame-by-frame, with no proxies required.

Thank you all for your help and ideas.

I can now quite literally edit videos for my YouTube channel anywhere, from a laptop that cost me £32 (I will of course make a video about that)!

Shotcut 1, KDEnlive 0 (seriously though, I’m not keeping score, I recognise the work that goes into software).

I’ll have to make a script on my “proper” PC so it can do all the heavy lifting of conversion on footage import.

That way I can ensure all files in the scratch directory (which is synced with the laptop) are converted, or at least have their frame rate locked (using ffmpeg maybe).

If I have to import on the go (drone footage and the like) I can use my custom preset al-la Brian’s method. And put a cup of tea or two on while the little i3 chugs away.

Thanks again,

Steve

One further post to say, while batch convert (see above) does work as a solution. I’ve now got this working without needing to do that. Simply by changing the settings on my camera. so that the footage is h.264 / aac in an .p4 container.