Killer bug: timeline is dead


#1

A killer bug is the opposite of a killer feature: a reason why a software is absolutely unusable. And this is exactly what I see right now with Shotcut (version 17.05.02 on a Lenovo Thinkpad 430s, 64bit, with OpenSuse Leap 42.3 system).

And this bug is plain simple: for me Shotcut has no functional timeline - and with this it is simply not a video editor! It shows only the word “Timeline” - and does nothing.

This is a pity because otherwise the software looks promising!

A search has only shown me that this killer but was already discussed years ago (like here), and it seems that it happened on many systems, but the discussion was closed without a solution. Later discussions (like here were closed even with a simple link to the other unsolved thread, so it looks to me like the developers have the impression that they “have done what is possible”!

And no, it is also not “poor OpenGL” I would say because I am working with rather demanding OpenGL software (ParaView) every day on the same computer. Still it might of course be some specific OpenGL function - no idea.

Overall this is a pity, so I simply want to reopen the issue because for those who are affected it is not just a little nuisance, but it makes the software plain unusable.

In other words: It is a killer bug and should be kept open until somebody finds a real solution! Because also restarting the app is not a workaround - because the problem remains after the restart: The timeline is not sometimes not working, but never working at all - from the very beginning.

Last words: I do not want to be rude with or frustrate the volonteer developers who might not see themselves able to fix the software: I am always very happy with all the work they are putting into a lot of powerful Open Source software - and I am trying to add my own share on other construction sites! Still I am now trying to find another video editing software - simply one that works.


#2

One thing to consider is you’re working with a severely outdated version of Shotcut. Latest is 18.11.18. At the top the window there is a “Download” link to hit so you can download the latest version.

Shotcut Minimum specifications.
Lenovo Thinkpad 430s Specifications.
Seems you’re really close to the minimum specifications for Shotcut.

Many others have posted in here having problems with low end computer specifications as well.

For you it’s unusable. For me, on my Windows 10 (i7-7700k, 32GB) machine works like a charm. Sure there are a few bugs, but nothing that makes me want to move on. Edited many videos with Shotcut. With very active development of Shotcut it’s definitely worth learning if you can get a better computer to learn it with.


#3

I mean I can accept that with lower performance hardware you have lower performance, but if I see the “Shotcut Minimum Specifications” they are absolutely met. For example “ParaView” finds the following OpenGL information:

OpenGL Vendor: Intel Open Source Technology Center
OpenGL Version: 3.3 (Core Profile) Mesa 17.0.5
OpenGL Renderer: Mesa DRI Intel® Ivybridge Mobile

Sure this is not a dedicated high-end graphic card which you might buy if you are doing video editing every day, but it is definitely more than the required version 2.0. And ParaView which is also rather demanding regarding video output - has not the slightest compatibility issues.

The link for automatic update is not working in my software: If I click on it - the software simply disappears (crash). So this is not an option either.

However, from what I see on the shotcut.org web site it looks to me like the Windows and maybe Mac versions are much more seriously maintained, while for the Linux world they are trying some packaging tricks in an attempt to be mostly independent from what the underlying system is offering - and this is of course a dangerous and not very reliable approach. In other words: It is a bit a question of good luck if you get it running or not on a Linux system!

Bottom line: If you do not want to fiddle around endlessly try to find another software - which is not so easy!

Blender works well - but for a sporadic user like myself it always means to redo a 2-3 hours tutorial before I can do a little 10min video cut or editing - because the user interface is so far from anything you know from any other place! But once you are there - nothing to complain of course.

The point is that I was looking for an alternative for a more sporadic user.

Still nice to hear that also the Shotcut tool is working for others!


#4

You could try Kdenlive. It works very well with Linux. A bit buggy with Windows.
Kdenlive is maintained mainly for Linux. Windows and Mac are secondary.

Shotcut, both the Windows and Linux Fedora work well for me. But I’ve found Kdenlive to be very robust and very capable.


#5

You can install multiple versions Shotcut of any OS, you don’t need the same directory. You can keep your old version if you wish.

You didn’t look deep enough.
https://shotcut.org/download/
https://shotcut.org/blog/

All updates happen across all OS’s at the same time.
On FossHub


On GitHub


#6

@shotcut has stated in posts that GPU processing is not supported.

I have a GTX-1070, but I don’t use it for any video editing. Video Editing is CPU intensive. And my CPU is water cooled with a 240mm radiator, with 2 fans on the radiator.

Perhaps those experienced with Linux can help out with installation, as I have almost no experience with Linux. Well, I did try Ubuntu 14.? with grub dual boot Win 7 a number of years ago. Two strikes right there, bad Linux distro and the noob, lol.

I hope you get it figured out. :slight_smile:


#7

From the videos I’ve seen of Kdenlive, makes me want to convert to Linux, lol. Sorry @sauron , for jumping over your post, didn’t see you responded. Yes, for me, Kdenlive is very buggy. It appears they just stopped trying to develop it any further for Windows. And it’s like well here you go, if you want it, lol. But I think there is a disclaimer before you download for Windows that they did stop development on it and it does contain bugs. I would love to use it. I may build a Linux machine by the end of the year yet just so I can Kdenlive out.


#8

Have you tried the AppImage download for Linux? Those have always worked perfectly for me on Linux Mint 18.3. Solid stuff, no luck required.


#9

Thanks for the hint: Maybe this is still worth a try! My understanding is that this AppImage system simply tries to pack all dependencies into one single package and run it in some kind of container. And my guess is indeed that my problem on my system is not the “lack of power” or anything, but simply incompatibilities between library versions etc, and a rather sloppy adjustment to OpenSuse Leap 42.3.

I took the software from official OpenSuse repositories in order to avoid this, and the fact that it still happens gave me the impression that it is indeed neglected by “somebody”: maybe not the maintainers of the software, but the maintainers of the OpenSuse repositories…!??

Btw, I tried many other video editors alreay, with a lot of bad luck, but “somehow” liked Shotcut - which is basically the only reason why I posted here at all: A slight chance to still maybe find a solution or at least a workaround that really works…

Fallback solution would otherwise be Blender: I already did some video editing with it, it was stable and powerful and all I needed, but it is a couple of months ago and I am afraid I wouild have to go through another tutorial of several hours to get back into that really strange user interface logic! And then in another couple of months later… Ok, maybe even my brain will pick it up after some time!

But then I just hear from my son that they are on the way to completely rework their user interface, so maybe there is still a chance?


#10

Good news for me: The AppImage seems to make it happen indeed! I just downloaded the AppImage file, made it “executable” and started it: one second later I had a ShotCut running INCLUDING a timeline - and saying it is “version 18.11.18”.

Nothing else done so far, but with now having a timeline the future of that software on my system looks already MUCH better.

It’s this my first “AppImage” software that I am using; I only read about it - and of course there may be disadvantages regarding automatic updates etc. etc.

Anyway: special thanks to “Austin” who put me on the right track!


#11

Glad to hear it’s working! AppImage has been the saving grace of the Linux ecosystem for me. It’s so reliable and simple that I pretty much won’t even consider a Linux program unless its deployment methods are AppImage or unpack-and-run. For Linux boxes that are air-gapped, AppImage also makes adding new programs much easier than PPA or other package managers do.

In regards to automatic updates, those don’t really happen with AppImage as you suspected. Simply download the new AppImage and run it from then on.

This all-in-one packaging is especially wonderful for video editing programs, and is a big reason I like Shotcut so much. For instance, I made a lot of videos with the 18.03.06 version, which had a track compositing button that no longer exists in 18.11.18. If I render those projects with the newer versions of Shotcut, the tracks don’t composite the same. I have to go back to 18.03.06 to get the same type of render. This isn’t unique to Shotcut. Plenty of other editors have forward- and backward-compatibility issues, and editing always works best on the version that created the project. With AppImage, I can keep all the older versions of Shotcut lying around indefinitely, meaning I can fire up any version I need at any time to recreate any old project. It’s an archivist’s dream.