Keyframing A Title

Why, when I change the size of a title using a keyframe, it changes the position?

Sizing a clip is done from its center by default.
The position of a clip is defined in relation to its upper left corner.

When you change the size of the clip, all corners will change position, including the top left one.

If you set the Horizontal and Vertical fits to Left and Top respectively, the Position values wont change when you resize the clip.

Thank you. If I wanted a title to have its start position in the middle of of the frame at 0 size (invisible) and then zoom to a given size straight in to the middle (end in same position as start), how would I do that?

Here’s one way to do it.
Maybe you already know most of what I’ll explain here, but I added as much details I could for the benefit of the less experienced users.

1- Choose your Text filter.

  • Text: Simple is quick, easy and is suitable for most needs.
  • Text: Rich Offers more text format options, but some people experience issues when using it.
  • In my example bellow, I’ll use the Text: Simple filter

2. Create your title

  • Go to Open Other, choose Text and click OK.
  • Drag the Text clip from the Preview panel to an empty track in the Timeline. Move the clip at the time position when the Title will start to appear.
  • Input the text of your title and format the text to your liking (font, size, color etc…).
  • In Vertical fit, choose Middle.
  • Enable a 2 by 2 grid in the Preview panel.
  • In the preview panel, grab the moving handle (round dot) and snap it to the intersection of the two lines in the grid. Your title is now centered on the screen.
  • Note: Depending on the font you use, you might need to adjust the Vertical position to move the text exactly to the middle of the screen.

3- Create the Zoom animation.

  • Add a Size, Position & Rotate filter.
  • Move the Playhead to the position when you want the zoom animation to end. You can use the Page Down key on your keyboard to move the Playhead by increments of one second.
  • Enable Keyframes. A new keyframe is created at the position of the playhead.
  • Move the Playhead to the first frame of the clip.
  • Change the Zoom value to 1 (it won’t accept 0)

And you’re done.

1 Like

Thank you so much for the detailed explanation.

1 Like

Works great, one other question: how do I increase the speed with which the text appears?

Just change the position of the keyframes :slight_smile:

Thank you, all is good.

This topic was automatically closed after 90 days. New replies are no longer allowed.