Keyframe Export Issue

I have run into an issue using keyframes. I was recently introduced to them, and this was my first time using them, so it may just be some checkbox I don’t know about. But basically, after using the keyframes to add some movement effects to images in my video, and then exporting the video, the animations were not in the final project. I assumed that maybe this was due to me adding too many, as shotcut tends to glitch alittle when 10+ minutes of edited footage are in the timeline, so I tested it on a small clip to see if I could make it work with only 1 animation on a single picture for 6 seconds, but it still didn’t show up in the final exported video. I’ve tried also different formats, switching to hardware encoding, and downloading a clean install of shotcut, but none have worked. Again, I assume its much simpler than I’m thinking, as I tend to have bad luck with software lol

I did also test to see if what I call “computer clown logic” was happening, where I’ll export a video and it will be broken, but if I view it back in the editing software, or just upload it to youtube and watch it, it will magically work, but not this time unfortunately

What version of Shotcut are you using? If you can post pictures of your project’s timeline in Shotcut that would also help too.

The version is the latest one, downloaded today, I don’t know the technical name
heres a screenshot of my timeline

I had not seen the rules for this forum saying that I should post more information, sooo heres some more if it helps
My computer specs are as follows
Intel I5 6600 K Quad core 3.5 GHz
Nvidia GTX 1060 ti Graphics card with 6 GB memory
16 GB RAM Memory

The video itself I’ve been trying to download at 60 fps 1080p, so far in both mp4 and WebM formats, and further testing using the aforementioned 2 second keyframe test animation, which also didn’t work, was attempted in .gif as well, with and without parallel processing, in both balanced and interlaced, in codec qualities of 55, 88, and 75%, and both with and without hardware encoding, and again, none of those changes worked. Again, I had also attempted a clean install of shotcut to no avail, implying that theres some setting that isn’t allowing it to work. I think I’m going to also try testing shotcut on my laptop to see if maybe its hardware-related, though I don’t get why that would be the case, but then again, it could be computer clown logic

ok, update
downloading shotcut on my laptop and doing a simple keyframe animation on it actually worked

soo maybe it was a hardware problem? Though that wouldn’t make much sense, given my laptop is much less powerful than my computer

regardless, I’ll try to copy all my assets onto the laptop and see if processing the video on it works, but i see this as more of a temporary fix, cuz I still need to get it to work on my main computer

Update
Attempts to bring the video to my laptop to edit have resulted in failure, as it crashes upon loading the .mlt file, even with all files required in the timeline. This happens no matter how short the video is, so its possible some sort of corruption has happened. Still as long as the original opens on my computer, theres still a chance to get this to work, if only theres some way to get it to export the keyframes. For tonight though, I have to call it a day. Please get back to me if you have any suggestions

of course, I could go back and remake the whole video on the laptop, but it may crash, plus I’d prefer to salvage the six hours of work I’ve spent on this video so far

When you downloaded Shotcut and re-installed it did you select the option to get rid of the parameters set in the Registry? If not, try again, this time selecting this option. That way you definitely get a completely clean install. Also, if you are using the GPU to export the video try switching this off and se if that fixes the problem.

aha! thanks. I had the hardware encoding on, but I didn’t know that was separate from the gpu rendering. Regardless, it works now

well… a sad note to end on
even though I got it to work in a test, my mtf file itself crashes shotcut when loaded, as well as older saves I made, which means all this must have corrupted them, which means I have to restart.
Well, at least this time I know it’ll work, so thanks again for your help