Keyframe Button Causes Frequent CRASHING *HELP*

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)

  1. Open any project
  2. Click on any media source in said project

    (Video or Photo)
  3. Add any filter with the ability to use keyframes
  4. Click the keyframe button.
  5. Crash the application, over and over and over.
1 Like

Hi @maztermac2

I’ve been testing v23.09.29 for a few days now and I don’t have any issues with adding keyframes. I’m also on Windows 10.

Have you tried rebooting your computer?
Or maybe something went wrong when installing v23.09.29 on your computer.
Try un-install / re-install Shotcut to see if this fixes the problem.

I have not reproduced it. Please see if it happens in a new project.

Neither this comment or the one above did anything, this is still the result

this didnt ever happen until I installed the new update…

I tried multiple times on Windows 10, 11, and Linux Flatpak. I also tried with GPU Effects turned on in Windows 10. Still unable to reproduce it. I do suggest a clean reinstall. The cleanest way is to reboot first, remove, and install before ever running Shotcut. If the problem continues, there is a chance the bug appears in a different way or reported with more information such that it is fixed in the next version. Then, downgrade in the meantime.

I clean rebooted and downgraded this is the result still

The video I posted above is V 23.07, it didnt have problems with that before;
correction: I had to downgrade to shotcut 22.12 It doesnt do this anymore, I’ll just cross my fingers and pray the next update doesnt have the same glitch.

I’ve been wrestling with the same situation and can reproduce it with 100% repeatability. Whenever I press the “add keyframe” button, like in the videos posted in this thread, Shotcut freezes then segfaults.

I’m running Shotcut 23.09.29, non-flatpack, on Fedora 38. This machine previously did not have any version of Shotcut installed.

Source RPM  : shotcut-23.09.29-1.fc38.src.rpm
Build Date  : Fri 06 Oct 2023 02:24:15 PM PDT
Build Host  :
Packager    : RPM Fusion

This happens with even the most trivial project containing a single clip, also like the other user’s videos.

This happens for me with the “Size, Position, Rotate” filter. I haven’t tried others.

edit: I uninstalled the RPM, rebooted, and installed the flatpack version. It does not exhibit the crashing/segfault from pressing the keyframe button. That sounds like a good thing. However, I can’t resize/maximize the window and the font sizes and icons are huge, so that’s not gonna work out. Other flatpack apps do not exhibit that behavior for me.

edit: Doh! The large font sizes were a result of having set “QT_SCALE_FACTOR = 1.3” in my .bashrc some time ago. Flatpack Shotcut is usable for me now. (Still was odd behavior with the larger-than-shotcut-could-handle scale factor.) So at least that’s something.