Key frame crash

Using windows 10. Latest version of shotcut (portable version) (24.02.29)

Just drag any file into the timeline, add a filter (size position / rotate)

Hit any of the the keyframe buttons and the app just immediately crashes. Happens every time. It seems all filters that support keyframe have this same bug. Brightness one does the same.

Even just creating a video from a single jpeg image will do it.

That’s not happening for me on Win11. Have you tried restarting your machine. Have you tried reinstalling Shotcut, make sure you also select Remove Shotcut settings from Registry

Tried restarting. It’s a portable version so I am not sure how to ‘reinstall’ it

I also don’t have any problem with keyframes on that version. I’m on Windows 10.

Ah yes I missed that, there’s no install in that case of course.

Maybe something wrong happened while unzipping Shotcut.
Delete your Shotcut folder, and try unzip it again maybe?

Extracted it to a fresh folder. Still the same behavior.

What are the specs of your computer? Is it 64 bits ?

core i7 3.4 gig
32gig of ram
rtx 3070
windows 10 64bits

I should ask, does shotcut have some temporary files / folders for settings that I can try deleting? Maybe that might help

how long is your particular video?
Maybe you ran out of RAM.
If this is the case, split up your videos into 10 to 30 min part videos.
You can do almost endless long videos. But the video clips, photos, cuts and so on can eat up your RAM. Depended on your RAM and your video elements you should limit the complexity by making part videos with the correct output format first and than combine the videos later in a master project file!

Ram is not an issue, i have 32gig. Happens if i create a project with just a single jpeg

Video of it. Happens with everything I try

You can go to Settings > App Data Directory > Show
I guess that cache, proxies and thumbnails are the folders containing temporary files you could delete.

i tried deleting the files but unfortunately the result was the same, still crashes :frowning:

Maybe there is something specific about your file. Can you share the image and the video mode you are using?

Hi Brian,
video mode is set to automatic. It happens with any file I load.

Have you tried from a different directory or a different drive?

Could you upload this file, the next time it crashes? (Drag/Drop works in this reply window for uploading the file)

Perform a full clean and reinstall the application. To do this you need to take these steps:

    • delete the application in the usual way through the application manager.
    • manually delete the C:\Program Files\Shotcut directory, if it exists after uninstallation.
    • manually delete the directory C:\Users\username\AppData\Local\Meltytech, if it exists after uninstallation.
    • delete the entry from the registry -HKEY_CURRENT_USER\Software\Meltytech
    • download the latest version and install.
      If these steps do not help, clean your computer of junk, for example, with a good open source application - BleachBit, this application will remove all junk from your computer, which theoretically could also interfere with the normal operation of the computer.
1 Like

The log file says this

[Info ] MainWindow::showStatusMessage “Hold Ctrl to drag a keyframe vertical only or Alt to drag horizontal only”
[Debug ] FiltersDock::resetQview begin
[Fatal ] <> Object 0x180bbc90980 destroyed while one of its QML signal handlers is in progress.
Most likely the object was deleted synchronously (use QObject::deleteLater() instead), or the application is running a nested event loop.
This behavior is NOT supported!
file:///D:/Shotcut/share/shotcut/qml/modules/Shotcut/Controls/KeyframesButton.qml:35: function() { [native code] }