Jumping and twitching Text with Basic-Textfilter

Hello there
i have been using Shotcut for a while now, mainly making small, bad videos and i want to take the time to thank all the folks working on this program. I’m always excited when it says, that a new version is available, as it was yesterday. I updated to 20.09.13 and saw the notification about the new “Text: Rich” filter. After i played around a bit, i must admit that i did not get the hang of it yet. I’m used to the deprecated HTML-Text-Filter, which mostly worked fine for my needs. Until i can familiarize myself more with the new filter, i used the basic Text-Filter to do the title in my video, but i now noticed, that the letters jump and twitch like a nervous Chihuahua. The Font i used is called “Bahnschrift” and should be a normal TT-Font (was included with Windows 10, as far as i remember). As a screenshot would not be really that helpful i take the liberty to link to the video in question:
https://www.youtube.com/watch?v=BneS5dI28ec (the Text comes up at 0:12)
Could someone maybe have a look at it and tell me what i did wrong there? As far as i remember i used only the textfilter on the videotrack (export was the Youtube MP4 profile).

Also, if someone knows of a good tutorial on how to get the most out of the new “Text: Rich”-Filter, that would be much appreciated.

Thanks and Cheers

Maybe a screen capture of your Shotcut window would be usefull.
Can you make sure you don’t have unwanted filters on the Output or on the header of the track where you’ve applied the Text: Simple filter ? If there are, you’ll see funnel-like icon(s) like this:


I watched the video and placed a cursor on the text and it did not appear to move.
I think it may be an illusion caused by the video behind the text.

Suggestions -

  • the outline on characters defaults to 3 - try 1.
  • The outline on characters is placed on the inside edge of the font, so the dark part of the character is reduced. I found it looks better with a medium weight font.
  • Put the text on a box or use background

Text on a box method 1
Just set the text background colour
Text on a box method 2
Add a size / position / rotate filter and size it to cover the text area
In the properties set a colour - this will affect the area defined by the size / position filter

Something weird happened…
I downloaded your video to check if an Audio Dance Visualization filter might reproduce the same twitching problem with the sound in the clip. Turned out it’s very unlikely.

The weird part is : Just after I downloaded the video, I’m 99.99% sure the twitching was visible in the video. But after a while, it disappeared. Now I play the video and there is no twitching on the text… (I swear, I’m not crazy)

So I downloaded it again but this time with the highest quality available for download : 1920x1080, 50fps (the first time I downloaded at 1920x1080, 25fps). The twitching was there, and after more than 30 minutes, it did not “fix” itself like the first one did.

Here’s a GIF capture of the first version I downloaded. The one that “fixed” itself:

And a capture of the second one (smaller here, to respect the 4096kb limit of the Forum) :

@LeKlein a screenshot of your timeline and listing all filters used around that time will greatly help. Is the text on it’s own transparent clip or is the text applied to the main video clip? To just view a video without knowing all of the factors will just result in a lot of guess work.

I will say playing the video on three quality settings the text moved around. Any setting lower, the text did not jump around.

A few other questions that may help would be:

  • Video Mode (Click on Output - then click on Properties)
  • Source Video Properties (Click on the source clip, then Properties)
  • Export settings. Did you use a preset on the left side? If so, what preset was used?
    • Did you enter Advanced and change any settings, if so, what was changed?

Hello Everyone, thanks for taking an interest in my question. When i saw @musicalbox’s comparison between the two download i became unsure if the error was in the exported video or only on youtubes presented versions. I can now confirm that the output out of shotcut indeed has jumpy text. In the preview, the text is normal.

As for the filters, there is only the Text: Simple active on that clip, no filters at all on the videotrack itself.

@Hudson555x, the question you mentioned i can answer as follows:
Video Mode (Click on Output - then click on Properties)
–> Video Mode is on Automatic
Source Video Properties (Click on the source clip, then Properties)
–> this is H.264 /AVC /MPEG-4, 2704x1520 at 50frames, Format is yuvj420p (Gopro5)
Export settings. Did you use a preset on the left side? If so, what preset was used?
Did you enter Advanced and change any settings, if so, what was changed?
–> I chose the Youtube-preset and went into the advanced settings and changed the codec quality from 55% to 75% and used h264_nvenc hardware encoding

The interesting part is for me, that not the whole video is affected but only the text itself. My only explanation as why the text did NOT jump for @Musicalbox is that a 25frames only even OR odd frames are shown which would eliminate the issue by skipping frames compared to 50frames source and youtube-reecoded versions.

Just for fun i cut down everything, leaving only one track and that single filter and exported a three second version of that clip. It too has jiggly-text :slight_smile:

I was looking for more specific information like exact resolutions and FPS of the Video Mode and the Source clip. So I’m guessing that your video mode is 2704x1520 @ 50.00000 fps, with matching source clip information.

shotcut_2020-09-16_18-29-20 shotcut_2020-09-16_18-49-26

The clip did move for me.
Here is proof.

Currently, there is no option to view 2.7k on YouTube, and the highest setting I can select is 1440p.

One thing you could try is putting text on a transparent clip above your video.

  1. Try with Export > Video > parallel processing turned off
  2. Try without using hardware encoder

If you still have the problem, please upload this short project file.

Sorry for replying so late, but i couldn’t get back to my PC until now.
@Hudson555x, your assumption is correct regarding the resolution and FPS. I will try the overlay, thanks for the hint.
@shotcut, now your hint produced some results. I did four exports with the following happening:

  1. Default settings, with hardware encoding, with parallel processing: Jiggly text (like in my uploaded video)
  2. Default settings, with hardware encoding, NO parallel processing: NO Jiggly text
  3. Default settings, NO hardware encoding, with parallel processing: Jiggly text
  4. Default settings, NO hardware encoding, NO parallel processing: NO Jiggly text
    So it seems that the parallel processing messes up the text. I can work around the issue now that you have shown me how. Would you be interested in some Logfiles or more info about my PC in case you want to follow up and that?

Let me know and in the meantime: Thanks to everybody for helping me out here!

Best regards


1 Like

I reproduced this bug. In addition to the Parallel processing, the font typeface does seem to matter. I am not seeing it with Arial, Verdana, or Tahoma. I have not found a reason for it, and logs will not help - only very deep debugging.

This topic was automatically closed after 90 days. New replies are no longer allowed.