Jerky play during editing

Hi there I a fairly new to Shotcut, having just switched from Lightworks. I have a problem that when I load a mp4, 1080/50m clip for editing it plays very slightly jerky. If I edit and export the jerky motion does not appear in the finished product when played on my pc or when posted to utube. This is not a problem I had had previously when using Lightworks, but I do not want to go back, as I really like Shotcut and the things it can do - really appreciate some help please.

Does your PC meet the minimum requirements?
Have you set the video mode ‘before’ importing your source video?
Have you applied any filters?
Have you enabled ‘GPU Processing (experimental)’ ?

Not all video editors are created equal. Shotcut is currently on a perpetual development cycle.

Hi Steve, thanks for such a quick and helpful response.

Regarding the system requirements, I have 8mb RAM, the chip I have is Intel® Core™ i5-7200U CPU @ 2.50GHZ - 2.71GHZ, not sure if this is sufficient or not, don’t know if its one or two core.

I had the VDO mode set to auto, but have tried setting it to 1080 59, but it made no difference.

No filters, it jerks right from importing before I have done anything to it

I enabled the GPU Processing as you suggested, but again it made no difference.

Thanks for your help, appreciate any other thoughts you have to resolve this please


Actually it wasn’t a suggestion, it was a question - because it’s experimental it can cause problems…

Other thing to look for are Security programs running/scanning in the background. Other apps running in the background.
PC that hasn’t been rebooted in a while. Other CPU intensive tasks you might be doing (like open browser with YouTube playing) Anything.
Open Task Manager and see if something is hogging resources.
I assume it’s a laptop you have, make certain the vents are clear and it’s not overheating…

PS: Intel® Core™ i5-7200U is a 2-core CPU.

Thanks again for the help. Rebooted, closed everything down and just run Shotcut, still the same issue. It is a laptop, but its fairly new and I am really fussy where it goes, so hopefully vents are not clogged. I do work in a hot environment so I just sat in the aircon on quite a cool setting for a while and still the same issue. When I look at Task Manager Shotcut was using 100% of the CPU while it was running. So frustrating, wish I could get it sorted, do you have any other thoughts, please?

Hi River

Can I just ask you about your comment above - Shotcut running 100% of CPU resources. Was the instance of shotcut running so high listed under the programs/apps category or under the processes category?
I am wondering whether your experience may be related to an intermittent problem I reported myself.

It does sound a little different to the issue you are having. This is Task Manager before pressing play

and this is what its like when I press play

You’re right, that is quite different. Thanks for checking and responding though :slight_smile:

Frequently with laptops the Power Management system is set to ‘best battery life’ rather than ‘best performance’. If this is the case with yours change the power setting (it makes a big difference on my Surface Pro).

Also you can change the setting: Realtime (frame dropping) - unset it and the playback should be smoother, but obviously will not keep up to real time.

More than likely that it is just the way it is, and you will have to take it or leave it. We do not strive to have the optimal playback experience like some media players. If your clip has interlacing, then Shotcut will deinterlace the playback by default, and that might have an impact: see the Progressive and Deinterlacer options in Settings. Click Progressive to turn off deinterlacing.

Ok, thanks for your comment and suggestions. Still have the issue, but will live with it as the output is good and I like the programme. Mark

Hi, thanks for the comments, did try as you suggested , but still have the issue. It is only slight so will have to live with it. The output is good, and I like the programme which is the main thing!

1 Like