Issues with pen tablet

I usually use a pen tablet rather than a mouse, and there’s some issues:
(1) When I move the cursor across a boundary between two things it changes to a double arrow (as if you were going to move the boundary) and stays like that rather than changing back to normal. I can still click on buttons and after doing that the cursor will return to normal.
(2) Also on the timeline the cursor won’t change at the edge of a clip or highlight the boundary, although if I click in the right place I can still adjust it.
(3) On the timeline I can’t click on the scrollbar, instead it moves the playhead, as if the scrollbar wasn’t even there.
(4) On the filter list for example, I also can’t click on the scrollbar, and sometimes it starts scrolling down automatically, and other times when I hover over something it’ll highlight something a few spots down the list.
Originally I thought this might be a problem with my distribution (Ubuntu Mate 18.04 and Shotcut 19.12.16, same problem with 16.04 and 19.10.10; it’s an old Wacom Bamboo Tablet), but before I gave up I tried my mouse (which is plugged in at the same time) and everything worked fine. I don’t think I’ve had issues with any other programs (for example in GIMP you can set up the stylus/eraser separately, but they’ll work like a mouse without doing that). Display Method: OpenGL vs Software (Mesa) didn’t make a difference.

I uploaded two videos, one using the pen (bugged) and one using the mouse (correct).

Most of these seem like an issue between Qt and the input system. You can try the flatpak, which is a build against a more recent version of Qt - 5.1 2. I am unavailable to help any further in this area at this time.

I’m having troubles getting flatpak to work, so for now I’ll stick with the snap version and use the mouse. Thanks for your attention.