Invalid indication when I open file

I have been using shotcut for about a year. Today I got a big INVALID when I opened the file. I have copied it below. Can I save/recover the file or am I screwed?


You can recover.
But first…

All of us who do a lot of Shotcut have folders filled with MLT files that display in the system filesystem displays as INVALID.

But how did he get a 1920x1080 INVALID?
I had never seen that.

How did he “open” it?

I tried many things, a browser, the image viewer, GIMP…
Nothing worked then I discovered it.

How to get a 1920x1080 INVALID:
(Requires a big second monitor)

  1. Open Shotcut
  2. In Settings, select your External Monitor
  3. Open a folder containing an MLT file that displays the INVALID icon.
  4. In Shotcut, go to the Playlist tab.
  5. Drag the file icon from the folder to the Playlist.
  6. Double-click on the INVALID icon in Playlist


A 1920x1080 “INVALID”


How to fix the problem.


  • With Shotcut closed click on (or double-click on, depends upon your OS) the “INVALID” MLT file in the file folder


  • Open Shotcut
  • Click on Open File
  • Select that “INVALID” MLT file

You will get a problem popup, which looks like this:

  1. Hover over the first (top) “missing” file in the window
  2. Take note of the filename, and where Shotcut has been told it ought to be.
  3. Now double-click on that file.
  4. Use the system window that pops up to direct Shotcut where it can really find that file today.
  5. If any files still show as missing, repeat steps 1-5 again.
  6. When all the files are found, Click on File, Select Save As, and give the MLT file a new name.

Your project is saved.

This topic was automatically closed after 90 days. New replies are no longer allowed.