Interpolating imported low res images/videos

Help, I’m trying to work on a low ish resolution video 112x120, when I import stills shotcut seems to interpolate it, softening the edged of the pixels, whereas I need them to stay sharp and not bleed into the neighbours. I’ve set the project to the same 112x120 resolution, set interpolation to nearest neighbour, tried different images in different formats, .png, .jpg, .webp, but its still bluring the image.

The origonal still image is this 00test — ImgBB

After importing into shotcut and saving as a frame it looks like this 00test — ImgBB

You might have to zoom into the image to see the interpolation problem.

To repeat. import any low res image and it softens it, even if the project video size is the same.

Any help much appreciated.

Windows 10, version 20.11.28 64 bit

Pls… Do not make any topic a bug category. And the problem you are having is definitely not a bug.

You can try sharpen filter.

Also check do you have preview scaling enabled or disabled.

You are not experiencing scaling interpolation directly but rather indirectly through sub-sampled chroma. Nearly all video uses sub-sampled chroma.

If you use File > Export Frame… the image is coming from the player, and the player always uses sub-sampled chroma to reduce the data transfer over the PCI bus to a GPU or video card. Then, the sub-sampled chroma is up-sampled to make a RGB image. One way to remedy this is to use the Export panel with a preset from the alpha or stills category. These ask the engine to use RGB(A) for processing. Of course, this will only work if your video is RGB(A) or YUV 4:4:4, but I do not know what you are using.

Also, please be aware there are some filters that only process in Y’CbCr (aka YUV) sub-sampled chroma, but that is rare. There is a list in this reply.