Installing Shotcut on Linuxmint 17.2 trouble

Hello I have trouble to install shortcut on Linux 17.2.

Dowloaded Shotcut to downloads.

When i try to “open file” in downloads the “archive manager” opens a folder “shotcut”
That i try to unwrap(?) en creates a “shotcut folder” in “downloads”.
This contains a “folder shotcut” and an (folder) “icon shotcut”.

tried also in terminal:
sudo add-apt-repository ppa:haraldhv/shotcut
sudo apt-get update
sudo apt-get install shotcut

There is no Shotcut installed.

Please help…

Linux portable tar users :

No install required,

simply extract the archive and run it. You can drag the Shotcut folder to copy and move it wherever you want. If double-clicking the icon in your file manager does not launch Shotcut, open, and try double-clicking the shotcut shell script. Do not try to run bin/shotcut directly. You may need to install JACK from your distribution. Here is a page that lists some required packages for specific distributions

From :
And click on “Show downloads for GNU/Linux | macOS | Microsoft Windows | All” ->“GNU/Linux”

To me it works.


" If double-clicking the icon in your file manager does not launch Shotcut, open, and try double-clicking the shotcut shell script."


[Desktop Entry]
GenericName=Video Editor
Comment=Video Editor
Comment[de]=Programm zum Bearbeiten und Abspielen von Videodateien.
Exec=shotcut %F

I’m not pretty sure, what you mean with: …“gives”… (Where? What?)

Currently I’m working with Win7 creating 3D-models, so I made two pictures from my Linux Mint 18.1-64-KDE…

As you can see, I’ve made a folder “Shotcut”, wherein I downloaded the txz-file(s).
I unzipped those and…

…here you can see, how it looks like on my system.
All I, and actually also you, need to do then is to double-click on “Shotcut.desktop”. (“Shotcut.desktop” is a script, and you need to make it executable)


Hello Earlybite,

Thank you for your reaction! Danke fur deine antwort!

in “downloads” there is this folder of “Shotcut”. Here is the screenshot.

I gonna post this first to see how it look likes

When I double click “shotcut-linux-x86_64-190228.txz”:

Then "unwrap/extrack (?)" (Uitpakken):


Then I click "sluiten" (close):

double click the file "Shotcut" :

Double click "Shotcut.desktop" :

No video’s have been cut during this proces : )

I also tried with:
“libjack0” and “libjack-jackd2-0”

sudo apt-get install libjack0
sudo apt-get install lib-jackd2-0

In “download” there is now a folder “shotcut”:

When opening the folder “Shotcut”:

Double click the icon “movie cutboard with green note”, nothing happens!

Double click “”:

(can’t upload the next screenshot because the max as a novice is reached…


What you have done with that “Shotcut.desktop” file? Do you have renamed it?


The original/vanilla file “Shotcut.desktop” is executable?
It needs to executable!

My Exec part: Exec=sh -c “$(dirname “%k”)/ “%F””

Your Exec part (was): shotcut %F


What you have shown in one of your pics, is the text content of “Shotcut.desktop”. So, why is GEdit starting?


I would recommend to delete your current download of “Shotcut”, download it again to have a vanilla one (and make a backup from that vanilla download), decompress it by default and be sure that the file “Shotcut.desktop” is executable (Right mouse button -> Properties -> Permissions / checkmark Executable).


I just tested on Mint 17.2, and it is no longer compatible. I will have to update the download page. The last version that works is 18.10:

Hey mr. Shotcut,
Thanks for cl(e)arifying that!

@Earlybite: Thanks for the effort!

This topic was automatically closed after 90 days. New replies are no longer allowed.