Including MTS clips causing export problems

I’ve used Shotcut now for all of a month, making a few 10 minute videos from mp4 clips that my phone tells me are Full HD (1080P), 30 frames /sec. I create projects in “auto” mode and take the Default preset for export. Typically a 10 minute video takes around 30 minutes to export on my modest Dell laptop with 8 GB ram and an SSD. Ok, not fantastic, but I can live with it.

Now I have started a new project that so far has only 45 seconds of video, and it is taking also taking almost 30 minutes to export on the same hardware. And the exported video, 57 megs, doesn’t play. No errors, just instantly stops. The only thing really different about this project is that I have included a couple of clips from an old Canon Camcorder that are .MTS files. If I delete those clips, export times are normal and the exported video plays. I don’t see anything obviously wrong with the .MTS clips, they play fine. Also, fyi, they are not the first clips in the video.

Any suggestions?

W10 2004 , Shotcut 20.11.25 64 bit


1 Like

MPEG Transport Stream is designed for broadcast networks where you don’t tune in at the start - all the signalling is repeated throughout the file and not necessarily at the start.

Can you use Handbrake to create something more edit friendly before importing?

AVCHD (MTS) is supported, but when exporting turn off parallel processing. That can increase time significantly on sources like AVCHD that are slow to seek. You said the export result is not playing. Did you try playing it in Shotcut?

.MTS files are an abomination. ffmpeg does not play well with them. The camera model that generates the file doesn’t make a difference… I have Sony and Panasonic files that also stutter. It’s so bad that I convert to Edit Friendly every single MTS file before bringing them to the timeline, and never use the .MTS files directly.

EDIT: To avoid offending Simon @st599 whose expertise I respect, I am amending this post to clarify there’s often a difference between .MTS files as made by consumer cameras and MPEG-TS as used in network broadcast workflows. That’s usually where the train runs off the rails.

1 Like

Thanks for the response. I finally created a new dummy shotcut project containing only the mts footage and it strangely exported fine, slowly but fine. Now I have a .mp4 that works in my larger project with other .mp4 just fine, exports at normal speed and plays fine.

I never get a “Convert to Edit Friendly” prompt for MTS… actually those prompts prop up pretty randomly on clips from my pixel all shot with the same settings, but that is another issue. Is there a way I can force that “Convert to Edit Friendly”?


1 Like

Go to that clip’s Properties’ tab and click on the Convert button.

Terrific. Thanks.

This topic was automatically closed after 90 days. New replies are no longer allowed.