Importing MP3 screwed up layout and Shotcut now freezes



I added a 43 minute MP3 to my playlist and it’s mangled the interface somehow. Windows overlap and the video control buttons have moved to the bottom of the timeline if I can get them to appear at all. If I try and do anything the application freezes forcing me to kill it. Just upgraded to the new version and that’s exactly the same.

I managed to remove the MP3 that seems to have caused this and re-saved the project, but the problem remains. Any idea how I can fix this?


Never seen this happen, I can’t even imagine how it could be caused by importing an asset into the playlist.
Sounds like something else. But you haven’t told us anything about your OS and Shotcut version.

In any case, you can reset the UI.



Maybe it was a complete coincidence, but either way Shotcut is now useless to me.

…after a great run where it had been the only reliable, stable editor I’ve used in Linux.

I’m using the latest version of Shotcut with Linux Mint (Cinnamon). Whatever the current one is as it’s right up to date.


Does it happen only to that one project or shotcut in general?

If in general, then clean up the settings. Rename this directory and this file


(see )

If you need some clearer guidance, here’s a video:

If that doesn’t help a screenshot would be nice

If it’s specific to your project, you could try sharing the .mlt file with us. Check the file (it’s a text/xml file) for any words (username, filenames) that you want to keep private first. If you replace the words carefully, we should still be able to try out the project.

You can use for example to host your file and I think this forum has an upload feature too.

PS: What’s your screen resolution? (just in case you’re using a super small resolution and that somehow screws up shotcut’s UI)


It seems to be a problem that affects Shotcut in general because now it won’t even open an older project.

Thanks for the pointers, though I can’t find that config file or the folder. Maybe that’s because I’m running the self contained version and it really is completely self contained (that isn’t supposed to sound sarcastic, if it did). I’ve attached a screenshot of the floating timeline. It seems to come and go as it pleases, and if I can get it to play back the video/audio at all, it’s really choppy, then the interface seems to bleed into the desktop and remain there after I’ve killed the application.

My resolution is 1600x900.


Just a quick update - I wanted to switch my OS to something a bit lighter anyway so I scrapped everything and am now running Mint XFCE. Unfortunately Shotcut still doesn’t function properly. The interface is behaving itself now, but it freezes whenever I press play. I removed any MP3s, just leaving the video in the timeline and that didn’t achieve anything either.