Import a video and it plays with no sound in ShotCut

This subject has been raised before, but the solution I discovered has never been suggested either on this forum or on YouTube, so I do so here to help anybody else faced with this problem.

Yesterday I was asked by my partner to edit a Zoom video for her YouTube channel. I opened ShotCut, created a new MLT and dropped in the MP4 created by Zoom. It’s 177Mb and here’s what it looks like:


I pressed Play and was surprised to find there was no sound even though the Audio level was clearly moving up and down. I checked the following:

  • the MP4 played fine with sound in VLC
  • the MP4 wasn’t muted anywhere within ShotCut (as per all the suggestions I found online)
  • another MP4 I imported into my MLT did play sound

So I decided that the problem was the MP4, not ShotCut, or at least that the Zoom MP4’s codec was incompatible in some way with ShotCut. I dropped the MP4 into the free and wonderful AVS Video Converter and converted it into an AVI. It came out at 1.1Gb and here are its properties:


The good news was that I dropped the AVI into ShotCut and the sound played without any problem but the video quality was worse that I was looking for. So I opened up AVS again and converted the AVI into an MP4 which came out at 1Gb with the following properties:


I dropped this MP4 into ShotCut and the video quality was A+ and the sound played properly. Problem solved.

So, using VLC, I checked the codecs of both the original Zoom MP4 and the final, sound working, MP4 and learned the following. The original:


And now the final MP4:


Anyway, I hope this was interesting and hopefully helps somebody else who encounters a similar problem.

As an aside, after I found the solution by re-encoding the Zoom video, I suddenly thought “why don’t I ask ChatGPT?” Here was its answer:

If the MP4 video file plays sound in VLC, but not in ShotCut, there might be an issue with the audio codec used in the video file.

ShotCut uses the FFmpeg library to decode audio and video files, so you might want to check if the audio codec used in the MP4 file is supported by FFmpeg. Some audio codecs that are not supported by FFmpeg might cause the audio to not play in ShotCut.

You can also try converting the audio of the MP4 video file to a different format using a media converter like Handbrake, and then importing the converted file into ShotCut. This might help to solve the problem if the issue is caused by the audio codec.

Another thing you can try is to check the audio settings in ShotCut. Go to the Settings menu and select Audio Channels. Make sure the audio channels are set to the correct values for your video file.

If none of these solutions work, you might want to try importing the video file into a different video editor to see if the issue persists. If the audio plays correctly in another video editor, then the issue might be specific to ShotCut and you might want to contact the ShotCut support team for further assistance.

It’s very, very scary how good it is and wickedly fast. I’m glad I won’t be around in a couple of decades. Skynet is coming. In the meantime, my partner is delighted with her Zoom video which was done by a human (for now) and means she’s still cooking me delicious meals (for now).

Very clever of a thing I see :wink:, chatgpt is useful tool that may prove to be worth…

Infact your idea to use chatgpt solved the problem of my crowdrendering too…

1 Like

Did you do this?

One difference between your files is that the original is mono and your converted file is stereo. The symptom you describe would also occur if your audio channel setting is set to 6 channels instead of 2 channels.

My audio settings are set to 6 (5.1). But then it’s also set to that with the MP4 that did work… I’ll set it to 2 on a new MLT and see if that original file works.

Nope. Made no difference I’m afraid.

Can you share a screenshot of this (with the file that does not work)? If the meters are moving, then sound should come out (regardless of the source file).

I just opened the file again, no sound playing once again, in order to take the screenshot you asked for and wondered what the Audio setting was. I had set it to 2 channel earlier on, as already mentioned, but it had reverted to 6 (5.1). So I set it to 2 channel once again and, hey presto, the sound came on!! So I apologise for my earlier “Nope” and will make a point of checking this setting if ever I encounter this again.

Many thanks for the troubleshooting assist!!

This topic was automatically closed after 90 days. New replies are no longer allowed.